Re: [PATCH v3 2/4] loose: lift loose object index parsing logic into helper
Justin Tobler <jltobler@gmail.com> writes:
Show 13 quoted lines
> diff --git a/loose.c b/loose.c
> index c6f4ee0ec6..5f72c644f9 100644
> --- a/loose.c
> +++ b/loose.c
> @@ -48,67 +48,88 @@ static int insert_oid_pair(kh_oid_map_t *map, const struct object_id *key, const
> return 1;
> }
>
> -static int insert_loose_map(struct odb_source_loose *loose,
> +static int insert_loose_map(struct loose_object_map *map,
> + struct oidtree *cache,
> const struct object_id *oid,
> const struct object_id *compat_oid)
Nit: with the introduction of `loose_object_map_read()`, perhaps makes
sense to keep naming consistent and rename this to
`loose_object_map_insert()`?
[snip]
The changes look good.