Re: [PATCH 2/2] [GSOC] cat-file: merge two block into one
- From
ZheNing Hu <adlternative@gmail.com>
- Date
- Jun 2, 2021, 13:27 UTC
- Message-ID
- <CAOLTT8QfvRQdLOhHUsK63Z_8K2VsRq1umwFCNVhHKeodtu7BNw@mail.gmail.com>
- In-Reply-To
- <YLZYZS8jBiOJynbz@coredump.intra.peff.net>
Jeff King <peff@peff.net> 于2021年6月1日周二 下午11:55写道:
Show 11 quoted lines
> > On Tue, Jun 01, 2021 at 02:35:57PM +0000, ZheNing Hu via GitGitGadget wrote: > > > From: ZheNing Hu <adlternative@gmail.com> > > > > Because the two "if (opt->all_objects)" block > > are redundant, merge them into one, to provide > > better readability. > > Funny indentation of the commit message. :) >
Yes, there is a small space that I didn’t notice. :)
Show 6 quoted lines
> I think this is worth doing, and I agree the end-result is easier to > read. Really minor nit, but I probably wouldn't have said "redundant" > here. The conditionals themselves are redundant, but not the blocks. > Maybe: There are two "if (opt->all_objects)" blocks next to each other; > merge them into one to provide better readability. >
Yeah, your expression is correct.
> (not a huge deal, as I think seeing the patch helps explain what is > going on. But again, just trying to offer polishing advice for future > patches)
Thanks. -- ZheNing Hu