Re: [PATCH v6 2/3] Makefile: add Perl runtime prefix support
- From
- Martin Ågren <martin.agren@gmail.com>
- Date
- Mar 19, 2018, 21:32 UTC
- Message-ID
- <CAN0heSpu4Lv9P+zzKPgJe3nx+J20Yex9is8SCztKobLc5ZfWCA@mail.gmail.com>
- In-Reply-To
- <20180319025046.58052-3-dnj@google.com>
On 19 March 2018 at 03:50, Dan Jacques <dnj@google.com> wrote:
Show 6 quoted lines
> Add a new Makefile flag, RUNTIME_PREFIX_PERL, which, when enabled, > configures Perl scripts to locate the Git installation's Perl support > libraries by resolving against the script's path, rather than > hard-coding that path at build-time. > > RUNTIME_PREFIX_PERL requires that system paths are expressed relative to
This commit message mentions RUNTIME_PREFIX_PERL twice, but there is no use of RUNTIME_PREFIX_PERL in the actual diffs (patches 1-3/3). Should it be s/_PERL//? Your cover letter hints as much under "Changes in v6 from v5". And "Add a new Makefile flag ..." would need some more rewriting since this patch rather expands the scope of the existing flag?
> a common installation directory, and uses that relationship to locate > support files based on the known starting point of the script being > executed, much like RUNTIME_PREFIX does for the Git binary.
With s/_PERL//, this part above reads a bit odd. Would this be s/RUNTIME_PREFIX/it/?
Martin