Re: [PATCH 4/5] diff: introduce diff.submoduleFormat configuration variable
- From
Ramkumar Ramachandra <artagnon@gmail.com>
- Date
- Oct 29, 2012, 10:30 UTC
- Message-ID
- <CALkWK0nPJ-8UvyYN800-Tj+mLQtv-vF3SJScb1O8EEiY238Z6w@mail.gmail.com>
- In-Reply-To
- <506C4161.3040201@web.de>
Jens Lehmann wrote:
Show 16 quoted lines
> Am 02.10.2012 21:44, schrieb Jens Lehmann:
>> Am 02.10.2012 18:51, schrieb Ramkumar Ramachandra:
>>> Introduce a diff.submoduleFormat configuration variable corresponding
>>> to the '--submodule' command-line option of 'git diff'.
>>
>> Nice. Maybe a better name would be "diff.submodule", as this sets the
>> default for the "--submodule" option of diff?
>>
>> And I think you should also test in t4041 that "--submodule=short"
>> overrides the config setting.
>
> We also need tests which show that setting that config to "log" does
> not break one of the many users of "git diff" ("stash", "rebase" and
> "format-patch" come to mind, most probably I missed some others). I
> suspect we'll have to add "--submodule=short" options to some call
> sites to keep them working with submodule changes.Um, why would "stash", "rebase" or "format-patch" be affected by this setting? They don't operate on submodules at all. To be sure, I ran all the tests with the following diff and nothing broke.
Confused,
Ram
-- 8< --
diff --git a/t/test-lib.sh b/t/test-lib.sh index 514282c..904a81c 100644 --- a/t/test-lib.sh +++ b/t/test-lib.sh @@ -608,6 +608,8 @@ fi # in subprocesses like git equals our $PWD (for pathname comparisons). cd -P "$test" || exit 1 +git config test.submodule log + this_test=${0##*/} this_test=${this_test%%-*} for skp in $GIT_SKIP_TESTS