git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 13/18] revert: Introduce --reset to remove sequencer state

From
Ramkumar Ramachandra <artagnon@gmail.com>
Date
Aug 1, 2011, 17:52 UTC
Message-ID
<CALkWK0n+=wWBhhMHuxXj9Stz0fVT9Gy1V9EMh+nX9vmH6ngT3Q@mail.gmail.com>
In-Reply-To
<201107311601.43472.chriscool@tuxfamily.org>
Hi Christian,
Christian Couder writes:
Show 18 quoted lines
> On Thursday 28 July 2011 18:52:26 Ramkumar Ramachandra wrote:
>> @@ -765,17 +784,21 @@ static int pick_revisions(struct replay_opts *opts)
>>
>>       read_and_refresh_cache(opts);
>>
>> -     walk_revs_populate_todo(&todo_list, opts);
>> -     create_seq_dir();
>> -     if (get_sha1("HEAD", sha1)) {
>> -             if (opts->action == REVERT)
>> -                     die(_("Can't revert as initial commit"));
>> -             die(_("Can't cherry-pick into empty head"));
>> -     } else
>> +     if (opts->subcommand == REPLAY_RESET) {
>> +             remove_sequencer_state(1);
>> +             return 0;
>> +     } else {
>
> Maybe you could remove this "else" so that the indentation level is reduced.
This was intentional, mainly for stylistic reasons.  See [1].
Show 14 quoted lines
>> +             /* Start a new cherry-pick/ revert sequence */
>> +             walk_revs_populate_todo(&todo_list, opts);
>> +             create_seq_dir();
>> +             if (get_sha1("HEAD", sha1)) {
>> +                     if (opts->action == REVERT)
>> +                             die(_("Can't revert as initial commit"));
>> +                     die(_("Can't cherry-pick into empty head"));
>> +             }
>>               save_head(sha1_to_hex(sha1));
>> -     save_opts(opts);
>> -     save_todo(todo_list, opts);
>
> It looks like this save_todo() was not necessary in the first place because
> pick_commits() does a save_todo() before processing each commit.
Fixed in the earlier patch.  Thanks!
[1]: http://thread.gmane.org/gmane.comp.version-control.git/177960
Thanks.
-- Ram
Previous: Christian CouderNext: Ramkumar Ramachandra
Message 25 of 36 in “Sequencer for inclusion v4”
  1. 00/18 Sequencer for inclusion v4Ramkumar Ramachandra, Jul 28, 2011
  2. 01/18 advice: Introduce error_resolve_conflictRamkumar Ramachandra, Jul 28, 2011
  3. 02/18 config: Introduce functions to write non-standard fileRamkumar Ramachandra, Jul 28, 2011
  4. Jonathan NiederJul 28, 2011
  5. Ramkumar RamachandraJul 28, 2011
  6. 03/18 revert: Simplify and inline add_message_to_msgRamkumar Ramachandra, Jul 28, 2011
  7. 04/18 revert: Don't check lone argument in get_encodingRamkumar Ramachandra, Jul 28, 2011
  8. 05/18 revert: Rename no_replay to record_originRamkumar Ramachandra, Jul 28, 2011
  9. 06/18 revert: Eliminate global "commit" variableRamkumar Ramachandra, Jul 28, 2011
  10. 07/18 revert: Introduce struct to keep command-line optionsRamkumar Ramachandra, Jul 28, 2011
  11. 08/18 revert: Separate cmdline parsing from functional codeRamkumar Ramachandra, Jul 28, 2011
  12. 09/18 revert: Don't create invalid replay_opts in parse_argsRamkumar Ramachandra, Jul 28, 2011
  13. 10/18 revert: Save data for continuing after conflict resolutionRamkumar Ramachandra, Jul 28, 2011
  14. Jonathan NiederJul 28, 2011
  15. Ramkumar RamachandraJul 28, 2011
  16. 11/18 revert: Save command-line options for continuing operationRamkumar Ramachandra, Jul 28, 2011
  17. Christian CouderJul 31, 2011
  18. Ramkumar RamachandraAug 1, 2011
  19. 12/18 revert: Make pick_commits functionally act on a commit listRamkumar Ramachandra, Jul 28, 2011
  20. Christian CouderJul 31, 2011
  21. Christian CouderJul 31, 2011
  22. Ramkumar RamachandraAug 1, 2011
  23. 13/18 revert: Introduce --reset to remove sequencer stateRamkumar Ramachandra, Jul 28, 2011
  24. Christian CouderJul 31, 2011
  25. Ramkumar RamachandraAug 1, 2011
  26. 14/18 reset: Make reset remove the sequencer stateRamkumar Ramachandra, Jul 28, 2011
  27. 15/18 revert: Remove sequencer state when no commits are pendingRamkumar Ramachandra, Jul 28, 2011
  28. 16/18 revert: Don't implictly stomp pending sequencer operationRamkumar Ramachandra, Jul 28, 2011
  29. 17/18 revert: Introduce --continue to continue the operationRamkumar Ramachandra, Jul 28, 2011
  30. Christian CouderJul 31, 2011
  31. Ramkumar RamachandraAug 1, 2011
  32. Jonathan NiederAug 3, 2011
  33. Junio C HamanoAug 3, 2011
  34. Ramkumar RamachandraAug 3, 2011
  35. 18/18 revert: Propogate errors upwards from do_pick_commitRamkumar Ramachandra, Jul 28, 2011
  36. Ramkumar RamachandraJul 28, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.