Re: What's cooking in git.git (Jun 2013, #03; Thu, 6)
- From
Ramkumar Ramachandra <artagnon@gmail.com>
- Date
- Jun 10, 2013, 06:25 UTC
- Message-ID
- <CALkWK0kvSvK=bFJo13=yw+2EZmGyv46_DUEZaniYGCe7D_V2wg@mail.gmail.com>
- In-Reply-To
- <7v1u8bouam.fsf@alter.siamese.dyndns.org>
Junio C Hamano wrote:
> Revert 77c1305 and 3c3b46b
The core of the argument seems to be that __git_complete_revlist_file() is a misleading name for the completion done by archive and ls-tree, but __git_complete_file() is somehow a less misleading name? Irrespective of what the valid completions of the various commands are, I want to know which completion function will be _used_ when I'm reading the script. And that is __git_complete_revlist_file().
To me, it looks like mega-bikeshedding; a huge amount of time and effort going behind a non-functional variable rename (and the best part? the rename isn't getting us a "better" name; just a "historical" name). But whatever.