Re: [PATCH v20 31/48] receive-pack.c: use a reference transaction for updating the refs
On Tue, Jul 8, 2014 at 6:20 AM, Michael Haggerty <mhagger@alum.mit.edu> wrote:
Show 21 quoted lines
> On 06/20/2014 04:43 PM, Ronnie Sahlberg wrote:
>> Wrap all the ref updates inside a transaction.
>>
>> Signed-off-by: Ronnie Sahlberg <sahlberg@google.com>
>> ---
>> builtin/receive-pack.c | 96 +++++++++++++++++++++++++++++++++-----------------
>> 1 file changed, 63 insertions(+), 33 deletions(-)
>>
>> diff --git a/builtin/receive-pack.c b/builtin/receive-pack.c
>> index c323081..b51f8ae 100644
>> --- a/builtin/receive-pack.c
>> +++ b/builtin/receive-pack.c
>> [...]
>> @@ -647,6 +654,9 @@ static void check_aliased_update(struct command *cmd, struct string_list *list)
>> char cmd_oldh[41], cmd_newh[41], dst_oldh[41], dst_newh[41];
>> int flag;
>>
>> + if (cmd->error_string)
>> + die("BUG: check_alised_update called with failed cmd");
>
> s/check_alised_update/check_aliased_update/