git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v20 40/48] refs.c: add an err argument to delete_ref_loose

From
Michael Haggerty <mhagger@alum.mit.edu>
Date
Jul 8, 2014, 14:19 UTC
Message-ID
<53BBFDFE.5060902@alum.mit.edu>
In-Reply-To
<1403275409-28173-41-git-send-email-sahlberg@google.com>
On 06/20/2014 04:43 PM, Ronnie Sahlberg wrote:
Show 11 quoted lines
> Add an err argument to delete_loose_ref so that we can pass a descriptive
> error string back to the caller. Pass the err argument from transaction
> commit to this function so that transaction users will have a nice error
> string if the transaction failed due to delete_loose_ref.
> 
> Add a new function unlink_or_err that we can call from delete_ref_loose. This
> function is similar to unlink_or_warn except that we can pass it an err
> argument. If err is non-NULL the function will populate err instead of
> printing a warning().
> 
> Simplify warn_if_unremovable.

The change to warn_if_unremovable() is orthogonal to the rest of the commit and should be a separate commit.

Show 17 quoted lines
> Signed-off-by: Ronnie Sahlberg <sahlberg@google.com>
> ---
>  refs.c    | 33 ++++++++++++++++++++++++++++-----
>  wrapper.c | 14 ++++++--------
>  2 files changed, 34 insertions(+), 13 deletions(-)
> 
> diff --git a/refs.c b/refs.c
> index 92a06d4..c7d1f3e 100644
> --- a/refs.c
> +++ b/refs.c
> @@ -2544,16 +2544,38 @@ int repack_without_refs(const char **refnames, int n, struct strbuf *err)
>  	return ret;
>  }
>  
> -static int delete_ref_loose(struct ref_lock *lock, int flag)
> +static int add_err_if_unremovable(const char *op, const char *file,
> +				  struct strbuf *e, int rc)

This function is only used once. Given also that its purpose is not that obvious from its signature, it seems to me that the code would be easier to read if it were inlined.

Show 12 quoted lines
> +{
> +	int err = errno;
> +	if (rc < 0 && errno != ENOENT) {
> +		strbuf_addf(e, "unable to %s %s: %s",
> +			    op, file, strerror(errno));
> +		errno = err;
> +		return -1;
> +	}
> +	return 0;
> +}
> +
> +static int unlink_or_err(const char *file, struct strbuf *err)

The name of this function is misleading; it sounds like it will try to unlink the file and if not possible call error(). Maybe a name like "unlink_or_report" would be less prejudicial.

It might also make sense to move this function to wrapper.c and implement unlink_or_warn() in terms of it rather than vice versa.

Show 60 quoted lines
> +{
> +	if (err)
> +		return add_err_if_unremovable("unlink", file, err,
> +					      unlink(file));
> +	else
> +		return unlink_or_warn(file);
> +}
> +
> +static int delete_ref_loose(struct ref_lock *lock, int flag, struct strbuf *err)
>  {
>  	if (!(flag & REF_ISPACKED) || flag & REF_ISSYMREF) {
>  		/* loose */
> -		int err, i = strlen(lock->lk->filename) - 5; /* .lock */
> +		int res, i = strlen(lock->lk->filename) - 5; /* .lock */
>  
>  		lock->lk->filename[i] = 0;
> -		err = unlink_or_warn(lock->lk->filename);
> +		res = unlink_or_err(lock->lk->filename, err);
>  		lock->lk->filename[i] = '.';
> -		if (err && errno != ENOENT)
> +		if (res)
>  			return 1;
>  	}
>  	return 0;
> @@ -3603,7 +3625,8 @@ int ref_transaction_commit(struct ref_transaction *transaction,
>  		struct ref_update *update = updates[i];
>  
>  		if (update->lock) {
> -			ret |= delete_ref_loose(update->lock, update->type);
> +			ret |= delete_ref_loose(update->lock, update->type,
> +						err);
>  			if (!(update->flags & REF_ISPRUNING))
>  				delnames[delnum++] = update->lock->ref_name;
>  		}
> diff --git a/wrapper.c b/wrapper.c
> index bc1bfb8..740e193 100644
> --- a/wrapper.c
> +++ b/wrapper.c
> @@ -429,14 +429,12 @@ int xmkstemp_mode(char *template, int mode)
>  
>  static int warn_if_unremovable(const char *op, const char *file, int rc)
>  {
> -	if (rc < 0) {
> -		int err = errno;
> -		if (ENOENT != err) {
> -			warning("unable to %s %s: %s",
> -				op, file, strerror(errno));
> -			errno = err;
> -		}
> -	}
> +	int err;
> +	if (rc >= 0 || errno == ENOENT)
> +		return rc;
> +	err = errno;
> +	warning("unable to %s %s: %s", op, file, strerror(errno));
> +	errno = err;
>  	return rc;
>  }
>  
> 
Michael
-- 
Michael Haggerty
mhagger@alum.mit.edu
Previous: Ronnie SahlbergNext: Ronnie Sahlberg
Message 64 of 99 in “Use ref transactions”
  1. 00/48 Use ref transactionsRonnie Sahlberg, Jun 20, 2014
  2. 01/48 refs.c: remove ref_transaction_rollbackRonnie Sahlberg, Jun 20, 2014
  3. 02/48 refs.c: ref_transaction_commit should not free the transactionRonnie Sahlberg, Jun 20, 2014
  4. 03/48 refs.c: constify the sha arguments for ref_transaction_create|delete|updateRonnie Sahlberg, Jun 20, 2014
  5. 04/48 refs.c: allow passing NULL to ref_transaction_freeRonnie Sahlberg, Jun 20, 2014
  6. 05/48 refs.c: add a strbuf argument to ref_transaction_commit for error loggingRonnie Sahlberg, Jun 20, 2014
  7. 06/48 lockfile.c: add a new public function unable_to_lock_messageRonnie Sahlberg, Jun 20, 2014
  8. 07/48 lockfile.c: make lock_file return a meaningful errno on failureiRonnie Sahlberg, Jun 20, 2014
  9. Michael HaggertyJul 8, 2014
  10. 08/48 refs.c: add an err argument to repack_without_refsRonnie Sahlberg, Jun 20, 2014
  11. 09/48 refs.c: make sure log_ref_setup returns a meaningful errnoRonnie Sahlberg, Jun 20, 2014
  12. 10/48 refs.c: verify_lock should set errno to something meaningfulRonnie Sahlberg, Jun 20, 2014
  13. 11/48 refs.c: make remove_empty_directories always set errno to something saneRonnie Sahlberg, Jun 20, 2014
  14. 12/48 refs.c: commit_packed_refs to return a meaningful errno on failureRonnie Sahlberg, Jun 20, 2014
  15. 13/48 refs.c: make resolve_ref_unsafe set errno to something meaningful on errorRonnie Sahlberg, Jun 20, 2014
  16. Karsten BleesJun 26, 2014
  17. 14/48 refs.c: log_ref_write should try to return meaningful errnoRonnie Sahlberg, Jun 20, 2014
  18. 15/48 refs.c: make ref_update_reject_duplicates take a strbuf argument for errorsRonnie Sahlberg, Jun 20, 2014
  19. 16/48 refs.c: make update_ref_write update a strbuf on failureRonnie Sahlberg, Jun 20, 2014
  20. 17/48 update-ref: use err argument to get error from ref_transaction_commitRonnie Sahlberg, Jun 20, 2014
  21. 18/48 refs.c: remove the onerr argument to ref_transaction_commitRonnie Sahlberg, Jun 20, 2014
  22. 19/48 refs.c: change ref_transaction_update() to do error checking and return statusRonnie Sahlberg, Jun 20, 2014
  23. 20/48 refs.c: change ref_transaction_create to do error checking and return statusRonnie Sahlberg, Jun 20, 2014
  24. Michael HaggertyJul 8, 2014
  25. Ronnie SahlbergJul 14, 2014
  26. 21/48 refs.c: update ref_transaction_delete to check for error and return statusRonnie Sahlberg, Jun 20, 2014
  27. 22/48 refs.c: make ref_transaction_begin take an err argumentRonnie Sahlberg, Jun 20, 2014
  28. Michael HaggertyJul 8, 2014
  29. Ronnie SahlbergJul 14, 2014
  30. 23/48 refs.c: add transaction.status and track OPEN/CLOSED/ERRORRonnie Sahlberg, Jun 20, 2014
  31. Michael HaggertyJul 8, 2014
  32. Ronnie SahlbergJul 14, 2014
  33. 24/48 tag.c: use ref transactions when doing updatesRonnie Sahlberg, Jun 20, 2014
  34. Michael HaggertyJul 8, 2014
  35. 25/48 replace.c: use the ref transaction functions for updatesRonnie Sahlberg, Jun 20, 2014
  36. Michael HaggertyJul 8, 2014
  37. Ronnie SahlbergJul 14, 2014
  38. 26/48 commit.c: use ref transactions for updatesRonnie Sahlberg, Jun 20, 2014
  39. 27/48 sequencer.c: use ref transactions for all ref updatesRonnie Sahlberg, Jun 20, 2014
  40. Michael HaggertyJul 8, 2014
  41. Ronnie SahlbergJul 14, 2014
  42. 28/48 fast-import.c: change update_branch to use ref transactionsRonnie Sahlberg, Jun 20, 2014
  43. 29/48 branch.c: use ref transaction for all ref updatesRonnie Sahlberg, Jun 20, 2014
  44. 30/48 refs.c: change update_ref to use a transactionRonnie Sahlberg, Jun 20, 2014
  45. Michael HaggertyJul 8, 2014
  46. Ronnie SahlbergJul 14, 2014
  47. 31/48 receive-pack.c: use a reference transaction for updating the refsRonnie Sahlberg, Jun 20, 2014
  48. Michael HaggertyJul 8, 2014
  49. Ronnie SahlbergJul 14, 2014
  50. 32/48 fast-import.c: use a ref transaction when dumping tagsRonnie Sahlberg, Jun 20, 2014
  51. 33/48 walker.c: use ref transaction for ref updatesRonnie Sahlberg, Jun 20, 2014
  52. Michael HaggertyJul 8, 2014
  53. Ronnie SahlbergJul 14, 2014
  54. 34/48 refs.c: make lock_ref_sha1 staticRonnie Sahlberg, Jun 20, 2014
  55. 35/48 refs.c: remove the update_ref_lock functionRonnie Sahlberg, Jun 20, 2014
  56. 36/48 refs.c: remove the update_ref_write functionRonnie Sahlberg, Jun 20, 2014
  57. 37/48 refs.c: remove lock_ref_sha1Ronnie Sahlberg, Jun 20, 2014
  58. Michael HaggertyJul 8, 2014
  59. 38/48 refs.c: make prune_ref use a transaction to delete the refRonnie Sahlberg, Jun 20, 2014
  60. 39/48 refs.c: make delete_ref use a transactionRonnie Sahlberg, Jun 20, 2014
  61. Michael HaggertyJul 8, 2014
  62. Ronnie SahlbergJul 14, 2014
  63. 40/48 refs.c: add an err argument to delete_ref_looseRonnie Sahlberg, Jun 20, 2014
  64. Michael HaggertyJul 8, 2014
  65. Ronnie SahlbergJul 16, 2014
  66. 41/48 refs.c: pass the ref log message to _create/delete/update instead of _commitRonnie Sahlberg, Jun 20, 2014
  67. Michael HaggertyJul 8, 2014
  68. 42/48 refs.c: pass NULL as *flags to read_ref_fullRonnie Sahlberg, Jun 20, 2014
  69. 43/48 refs.c: move the check for valid refname to lock_ref_sha1_basicRonnie Sahlberg, Jun 20, 2014
  70. Michael HaggertyJul 8, 2014
  71. Ronnie SahlbergJul 15, 2014
  72. Jonathan NiederJul 15, 2014
  73. Jonathan NiederJul 15, 2014
  74. Junio C HamanoJul 15, 2014
  75. Ronnie SahlbergJul 15, 2014
  76. Ronnie SahlbergJul 15, 2014
  77. Ronnie SahlbergJul 15, 2014
  78. Michael HaggertyAug 20, 2014
  79. Ronnie SahlbergAug 20, 2014
  80. Jonathan NiederAug 20, 2014
  81. Ronnie SahlbergAug 20, 2014
  82. Michael HaggertyAug 20, 2014
  83. Ronnie SahlbergAug 21, 2014
  84. Junio C HamanoAug 20, 2014
  85. Michael HaggertyAug 20, 2014
  86. Junio C HamanoAug 20, 2014
  87. Ronnie SahlbergAug 20, 2014
  88. Michael HaggertyAug 22, 2014
  89. 44/48 refs.c: call lock_ref_sha1_basic directly from commitRonnie Sahlberg, Jun 20, 2014
  90. Michael HaggertyJul 8, 2014
  91. 45/48 refs.c: pass a skip list to name_conflict_fnRonnie Sahlberg, Jun 20, 2014
  92. 46/48 refs.c: propagate any errno==ENOTDIR from _commit back to the callersRonnie Sahlberg, Jun 20, 2014
  93. 47/48 fetch.c: change s_update_ref to use a ref transactionRonnie Sahlberg, Jun 20, 2014
  94. 48/48 refs.c: make write_ref_sha1 staticRonnie Sahlberg, Jun 20, 2014
  95. Michael HaggertyJul 8, 2014
  96. Junio C HamanoJul 8, 2014
  97. Jeff KingJul 9, 2014
  98. Ronnie SahlbergJul 14, 2014
  99. Ronnie SahlbergJul 14, 2014

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.