Re: [PATCH 0/9] Progress with git submodule
- From
Stefan Beller <sbeller@google.com>
- Date
- Aug 28, 2015, 16:35 UTC
- Message-ID
- <CAGZ79kbBfHUYJN1UBeynSAwfGhSmscarGnzSs9sZJmvN2m0VQg@mail.gmail.com>
- In-Reply-To
- <b5126a0a9438e8737c726d887ebc96e3@www.dscho.org>
On Fri, Aug 28, 2015 at 3:09 AM, Johannes Schindelin <johannes.schindelin@gmx.de> wrote:
Show 14 quoted lines
> Hi Stefan, > > On 2015-08-28 03:14, Stefan Beller wrote: > >> Stefan Beller (9): >> submodule: implement `module_list` as a builtin helper >> submodule: implement `module_name` as a builtin helper >> submodule: implement `module_clone` as a builtin helper > > Another thing that just hit me: is there any specific reason why the underscore? I think we prefer dashes for subcommands (think: cherry-pick) and maybe we want to do the same for subsubcommands... > > Ciao, > Dscho >
Junio wrote on Aug 3rd:
Show 7 quoted lines
>>> $ git submodule--helper module_list >> >> Why would you use an underscore in here as opposed to a dash? > > Simply because the diff would be easier to read; the callers used to > call module_list shell function, now they call the subcommand with the > same name of submodule--helper.
I mean no user is expected to use the submodule--helper functions directly and we want to get rid of them eventually anyway (once the whole git-submodule.sh is rewritten in C we can just call the C functions instead of calling out to helpers)