git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v7 19/31] merge-recursive: add get_directory_renames()

From
Stefan Beller <sbeller@google.com>
Date
Feb 3, 2018, 01:02 UTC
Message-ID
<CAGZ79kb2+tpr0K0x2VVfFR-u3W2htvbxokxfKBpG60mNjXGPEw@mail.gmail.com>
In-Reply-To
<20180130232533.25846-20-newren@gmail.com>
On Tue, Jan 30, 2018 at 3:25 PM, Elijah Newren <newren@gmail.com> wrote:
Show 26 quoted lines
> This populates a list of directory renames for us.  The list of
> directory renames is not yet used, but will be in subsequent commits.
>
> Signed-off-by: Elijah Newren <newren@gmail.com>
> ---
>  merge-recursive.c | 155 ++++++++++++++++++++++++++++++++++++++++++++++++++++--
>  1 file changed, 152 insertions(+), 3 deletions(-)
>
> diff --git a/merge-recursive.c b/merge-recursive.c
> index 40ed8e1f39..c75d3a5139 100644
> --- a/merge-recursive.c
> +++ b/merge-recursive.c
> @@ -1393,6 +1393,138 @@ static struct diff_queue_struct *get_diffpairs(struct merge_options *o,
>         return ret;
>  }
>
> +static void get_renamed_dir_portion(const char *old_path, const char *new_path,
> +                                   char **old_dir, char **new_dir)
> +{
> +       char *end_of_old, *end_of_new;
> +       int old_len, new_len;
> +
> +       *old_dir = NULL;
> +       *new_dir = NULL;
> +
> +       /* For
comment style.
    /*
     * we prefer to keep the beginning
     * and ending line of a comment free.
     */
    /* unless you write single line comments */
Show 5 quoted lines
> +        *    "a/b/c/d/foo.c" -> "a/b/something-else/d/foo.c"
> +        * the "d/foo.c" part is the same, we just want to know that
> +        *    "a/b/c" was renamed to "a/b/something-else"
> +        * so, for this example, this function returns "a/b/c" in
> +        * *old_dir and "a/b/something-else" in *new_dir.
So we would not see multi-directory renames?
    "a/b/c/d/foo.c" -> "a/b/something-else/e/foo.c"
could be detected as
    "a/b/{c/d/ => something-else/e}/foo.c"

I assume this patch series is not bringing that to the table. (which is fine, I am just wondering)

Show 9 quoted lines
> +        *
> +        * Also, if the basename of the file changed, we don't care.  We
> +        * want to know which portion of the directory, if any, changed.
> +        */
> +       end_of_old = strrchr(old_path, '/');
> +       end_of_new = strrchr(new_path, '/');
> +
> +       if (end_of_old == NULL || end_of_new == NULL)
> +               return;

return early as the files are in the top level, and apparently we do not support top level renaming?

What about a commit like 81b50f3ce4 (Move 'builtin-*' into a 'builtin/' subdirectory, 2010-02-22) ?

Well that specific commit left many files outside the new builtin dir, but conceptually we could see a directory rename of

    /* => /src/*
> +       while (*--end_of_new == *--end_of_old &&
> +              end_of_old != old_path &&
> +              end_of_new != new_path)
> +               ; /* Do nothing; all in the while loop */

We have to compare manually as we'd want to find the first non-equal and there doesn't seem to be a good library function for that.

Assuming many repos are UTF8 (including in their paths), how does this work with display characters longer than one char? It should be fine as we cut at the slash?

Show 21 quoted lines
> +       /*
> +        * We've found the first non-matching character in the directory
> +        * paths.  That means the current directory we were comparing
> +        * represents the rename.  Move end_of_old and end_of_new back
> +        * to the full directory name.
> +        */
> +       if (*end_of_old == '/')
> +               end_of_old++;
> +       if (*end_of_old != '/')
> +               end_of_new++;
> +       end_of_old = strchr(end_of_old, '/');
> +       end_of_new = strchr(end_of_new, '/');
> +
> +       /*
> +        * It may have been the case that old_path and new_path were the same
> +        * directory all along.  Don't claim a rename if they're the same.
> +        */
> +       old_len = end_of_old - old_path;
> +       new_len = end_of_new - new_path;
> +
> +       if (old_len != new_len || strncmp(old_path, new_path, old_len)) {

How often are we going to see this string-is-equal case? Would it make sense to do that first in the function?

Show 14 quoted lines
> +               *old_dir = xstrndup(old_path, old_len);
> +               *new_dir = xstrndup(new_path, new_len);
> +       }
> +}
> +
> +static struct hashmap *get_directory_renames(struct diff_queue_struct *pairs,
> +                                            struct tree *tree)
> +{
> +       struct hashmap *dir_renames;
> +       struct hashmap_iter iter;
> +       struct dir_rename_entry *entry;
> +       int i;
> +
> +       dir_renames = malloc(sizeof(struct hashmap));
xmalloc
Show 16 quoted lines
> +       dir_rename_init(dir_renames);
> +       for (i = 0; i < pairs->nr; ++i) {
> +               struct string_list_item *item;
> +               int *count;
> +               struct diff_filepair *pair = pairs->queue[i];
> +               char *old_dir, *new_dir;
> +
> +               /* File not part of directory rename if it wasn't renamed */
> +               if (pair->status != 'R')
> +                       continue;
> +
> +               get_renamed_dir_portion(pair->one->path, pair->two->path,
> +                                       &old_dir,        &new_dir);
> +               if (!old_dir)
> +                       /* Directory didn't change at all; ignore this one. */
> +                       continue;

So the first loop is about counting the number of files in each directory that are renamed and the later while loop is about mapping them?

> +               /* Strings were xstrndup'ed before inserting into string-list,
> +                * so ask string_list to remove the entries for us.
> +                */
comment style.
> +               entry->possible_new_dirs.strdup_strings = 1;

Why do we need to set strdup_strings here (so late in the game, we are about to clear it?) Could we set it earlier?

Or rather have the string list duplicate the strings instead of get_renamed_dir_portion ?

Previous: Elijah NewrenNext: Elijah Newren
Message 46 of 63 in “Add directory rename detection to git”
  1. 00/31 Add directory rename detection to gitElijah Newren, Jan 30, 2018
  2. Elijah NewrenJan 30, 2018
  3. 24/31 merge-recursive: when comparing files, don't include treesElijah Newren, Jan 30, 2018
  4. 28/31 merge-recursive: fix remaining directory rename + dirty overwrite casesElijah Newren, Jan 30, 2018
  5. Stefan BellerFeb 5, 2018
  6. Elijah NewrenFeb 5, 2018
  7. 05/31 directory rename detection: files/directories in the way of some renamesElijah Newren, Jan 30, 2018
  8. 06/31 directory rename detection: testcases checking which side did the renameElijah Newren, Jan 30, 2018
  9. 10/31 directory rename detection: tests for handling overwriting untracked filesElijah Newren, Jan 30, 2018
  10. 15/31 merge-recursive: make !o->detect_rename codepath more obviousElijah Newren, Jan 30, 2018
  11. Stefan BellerFeb 2, 2018
  12. 14/31 merge-recursive: fix leaks of allocated renames and diff_filepairsElijah Newren, Jan 30, 2018
  13. Stefan BellerFeb 2, 2018
  14. 23/31 merge-recursive: check for file level conflicts then get new nameElijah Newren, Jan 30, 2018
  15. 30/31 merge-recursive: avoid spurious rename/rename conflict from dir renamesElijah Newren, Jan 30, 2018
  16. 16/31 merge-recursive: split out code for determining diff_filepairsElijah Newren, Jan 30, 2018
  17. Stefan BellerFeb 3, 2018
  18. Elijah NewrenFeb 3, 2018
  19. 11/31 directory rename detection: tests for handling overwriting dirty filesElijah Newren, Jan 30, 2018
  20. 22/31 merge-recursive: add computation of collisions due to dir rename & mergingElijah Newren, Jan 30, 2018
  21. 31/31 merge-recursive: ensure we write updates for directory-renamed fileElijah Newren, Jan 30, 2018
  22. Stefan BellerFeb 5, 2018
  23. 20/31 merge-recursive: check for directory level conflictsElijah Newren, Jan 30, 2018
  24. Stefan BellerFeb 5, 2018
  25. Elijah NewrenFeb 5, 2018
  26. 25/31 merge-recursive: apply necessary modifications for directory renamesElijah Newren, Jan 30, 2018
  27. SZEDER GáborFeb 16, 2018
  28. 17/31 merge-recursive: add a new hashmap for storing directory renamesElijah Newren, Jan 30, 2018
  29. Stefan BellerFeb 3, 2018
  30. Elijah NewrenFeb 3, 2018
  31. Johannes SixtFeb 4, 2018
  32. Elijah NewrenFeb 5, 2018
  33. Junio C HamanoFeb 5, 2018
  34. Stefan BellerFeb 5, 2018
  35. Elijah NewrenFeb 5, 2018
  36. 21/31 merge-recursive: add a new hashmap for storing file collisionsElijah Newren, Jan 30, 2018
  37. Stefan BellerFeb 5, 2018
  38. 29/31 directory rename detection: new testcases showcasing a pair of bugsElijah Newren, Jan 30, 2018
  39. 27/31 merge-recursive: fix overwriting dirty files involved in renamesElijah Newren, Jan 30, 2018
  40. Stefan BellerFeb 5, 2018
  41. Elijah NewrenFeb 5, 2018
  42. 03/31 directory rename detection: testcases to avoid taking detection too farElijah Newren, Jan 30, 2018
  43. 01/31 directory rename detection: basic testcasesElijah Newren, Jan 30, 2018
  44. 04/31 directory rename detection: partially renamed directory testcase/discussionElijah Newren, Jan 30, 2018
  45. 19/31 merge-recursive: add get_directory_renames()Elijah Newren, Jan 30, 2018
  46. Stefan BellerFeb 3, 2018
  47. Elijah NewrenFeb 3, 2018
  48. Elijah NewrenFeb 4, 2018
  49. Eric SunshineFeb 4, 2018
  50. Eric SunshineFeb 4, 2018
  51. Stefan BellerFeb 5, 2018
  52. 18/31 merge-recursive: make a helper function for cleanup for handle_renamesElijah Newren, Jan 30, 2018
  53. Stefan BellerFeb 3, 2018
  54. 02/31 directory rename detection: directory splitting testcasesElijah Newren, Jan 30, 2018
  55. 13/31 merge-recursive: introduce new functions to handle rename logicElijah Newren, Jan 30, 2018
  56. Stefan BellerFeb 2, 2018
  57. 12/31 merge-recursive: move the get_renames() functionElijah Newren, Jan 30, 2018
  58. Stefan BellerFeb 2, 2018
  59. 09/31 directory rename detection: miscellaneous testcases to complete coverageElijah Newren, Jan 30, 2018
  60. 08/31 directory rename detection: testcases exploring possibly suboptimal mergesElijah Newren, Jan 30, 2018
  61. 26/31 merge-recursive: avoid clobbering untracked files with directory renamesElijah Newren, Jan 30, 2018
  62. 07/31 directory rename detection: more involved edge/corner testcasesElijah Newren, Jan 30, 2018
  63. Stefan BellerFeb 5, 2018

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.