Re: [PATCHv6 2/7] submodule helper: support super prefix
- From
Stefan Beller <sbeller@google.com>
- Date
- Dec 8, 2016, 20:19 UTC
- Message-ID
- <CAGZ79kagKKE7fiwdPGgLsaQuQV-Y2ePgPdTLkwZJ0T9UN9uH_Q@mail.gmail.com>
- In-Reply-To
- <CACsJy8AohKMTm0inUyxu=kTwxNFcCbbBRO=O126SCzi5e=0tSQ@mail.gmail.com>
> > unsigned int is probably safer for variables that are used as bit-flags.
done
> If it's meant for users to see, please _() the string.
done
Show 5 quoted lines
>> + { "submodule--helper", cmd_submodule__helper, RUN_SETUP | SUPPORT_SUPER_PREFIX},
>
> The same macro defined twice in two separate .c files? Hmm.. it
> confused me a bit because i thought there was a connection.. I guess
> it's ok.Its effect is exactly the same. just plain code duplication. I assume that is okay here as it really is only one constant for now. Maybe we can refactor that to be defined in a header file (but which? There is no such thing as a git.h, where I'd expect to put it.)
Thanks, Stefan