From: Stefan Beller Date: Thu, 08 Dec 2016 20:19:00 GMT Subject: Re: [PATCHv6 2/7] submodule helper: support super prefix Message-ID: In-Reply-To: > > unsigned int is probably safer for variables that are used as bit-flags. done > If it's meant for users to see, please _() the string. done >> + { "submodule--helper", cmd_submodule__helper, RUN_SETUP | SUPPORT_SUPER_PREFIX}, > > The same macro defined twice in two separate .c files? Hmm.. it > confused me a bit because i thought there was a connection.. I guess > it's ok. Its effect is exactly the same. just plain code duplication. I assume that is okay here as it really is only one constant for now. Maybe we can refactor that to be defined in a header file (but which? There is no such thing as a git.h, where I'd expect to put it.) Thanks, Stefan