Re: [PATCH] pack: make packed_git_mru global a value instead of a pointer
- From
Stefan Beller <sbeller@google.com>
- Date
- Sep 18, 2017, 17:26 UTC
- Message-ID
- <CAGZ79kZwt5zM1N1=418FHMLZPjMJV55kKbJoat6GT157dxZObA@mail.gmail.com>
- In-Reply-To
- <CAP8UFD2d7y9COGj=bRLk_d+F_M=c7nv802AjBf=R9NnJQB7ohA@mail.gmail.com>
On Sun, Sep 17, 2017 at 1:44 PM, Christian Couder <christian.couder@gmail.com> wrote:
Show 18 quoted lines
> On Sun, Sep 17, 2017 at 10:42 PM, Christian Couder > <christian.couder@gmail.com> wrote: >> On Sun, Sep 17, 2017 at 10:17 PM, phionah bugosi <bugosip@gmail.com> wrote: >>> Signed-off-by: phionah bugosi <bugosip@gmail.com> >>> --- >>> builtin/pack-objects.c | 5 +++-- >>> cache.h | 7 ------- >>> list.h | 6 ++++++ >>> packfile.c | 12 ++++++------ >>> 4 files changed, 15 insertions(+), 15 deletions(-) >>> >>> This patch makes packed_git_mru global a value instead of a pointer and >>> makes use of list.h >> >> Please explain _why_ you are doing that (why is the resulting code better). > > Also the explanations should be in the commit message, that is above > your "Signed-off-by: ..." line.
A similar patch exists at origin/jn/per-repo-object-store-fixes^^ (I haven't checked if there are differences and if so which patch is better, all I am noting here, is that there has been work very similar to this one a couple days prior)