git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [GIT PULL] vcs-svn housekeeping

From
David Michael Barr <davidbarr@google.com>
Date
Jul 6, 2012, 19:41 UTC
Message-ID
<CAFfmPPOWfYhZyrsvg8eeisdNLb4gyEMJ5kYfVhcSR3KNa-QjCQ@mail.gmail.com>
In-Reply-To
<20120706171040.GA31001@burratino>
On Sat, Jul 7, 2012 at 3:10 AM, Jonathan Nieder <jrnieder@gmail.com> wrote:
Show 42 quoted lines
> Hi Junio,
>
> The following changes since commit 58ebd9865d2bb9d42842fbac5a1c4eae49e92859:
>
>   vcs-svn/svndiff.c: squelch false "unused" warning from gcc (2012-01-27 11:58:56 -0800)
>
> are available at:
>
>   git://repo.or.cz/git/jrn.git svn-fe
>
> The first three commits duplicate changes that are already in master
> but were committed independently on the svn-fe branch last February.
> The rest are David's db/vcs-svn series which aims to address various
> nits noticed when merging the code back into svn-dump-fast-export:
> unnecessary use of git-specific functions (prefixcmp, memmem) and
> warnings reported by clang.
>
> Some of the patches had to change a little since v2 of db/vcs-svn, so
> I'll be replying with a copy of the patches for reference.
>
> David has looked the branch over and acked and tested it.
>
> Thoughts welcome, as usual.  I think these are ready for pulling into
> master.  Sorry to be so slow at this.
>
> David Barr (7):
>       vcs-svn: drop no-op reset methods
>       vcs-svn: avoid self-assignment in dummy initialization of pre_off
>       vcs-svn: simplify cleanup in apply_one_window
>       vcs-svn: use constcmp instead of prefixcmp
>       vcs-svn: use strstr instead of memmem
>       vcs-svn: suppress signed/unsigned comparison warnings
>       vcs-svn: suppress a signed/unsigned comparison warning
>
> Jonathan Nieder (4):
>       vcs-svn: allow import of > 4GiB files
>       vcs-svn: suppress -Wtype-limits warning
>       vcs-svn: suppress a signed/unsigned comparison warning
>       vcs-svn: allow 64-bit Prop-Content-Length
>
> Ramsay Allan Jones (1):
>       vcs-svn: rename check_overflow and its arguments for clarity

Thank you Jonathan for doing this. Definitely the result of collaborating on a series is gorgeous. I do wish I could absorb your flair for polish.

-- David Barr

Previous: Jonathan NiederNext: Junio C Hamano
Message 15 of 16 in “What's cooking in git.git (Jun 2012, #02; Wed, 6)”
  1. Junio C HamanoJun 6, 2012
  2. David Michael BarrJun 6, 2012
  3. Jonathan NiederJun 7, 2012
  4. Junio C HamanoJun 7, 2012
  5. [GIT PULL] vcs-svn housekeepingJonathan Nieder, Jul 6, 2012
  6. 1/9 vcs-svn: drop no-op reset methodsJonathan Nieder, Jul 6, 2012
  7. 2/9 vcs-svn: avoid self-assignment in dummy initialization of pre_offJonathan Nieder, Jul 6, 2012
  8. 3/9 vcs-svn: simplify cleanup in apply_one_windowJonathan Nieder, Jul 6, 2012
  9. 4/9 vcs-svn: use constcmp instead of prefixcmpJonathan Nieder, Jul 6, 2012
  10. 5/9 vcs-svn: use strstr instead of memmemJonathan Nieder, Jul 6, 2012
  11. 6/9 vcs-svn: suppress signed/unsigned comparison warningsJonathan Nieder, Jul 6, 2012
  12. 7/9 vcs-svn: suppress a signed/unsigned comparison warningJonathan Nieder, Jul 6, 2012
  13. 8/9 vcs-svn: suppress a signed/unsigned comparison warningJonathan Nieder, Jul 6, 2012
  14. 9/9 vcs-svn: allow 64-bit Prop-Content-LengthJonathan Nieder, Jul 6, 2012
  15. David Michael BarrJul 6, 2012
  16. Junio C HamanoJul 6, 2012

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.