git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 3/4] dir: introduce file_size() to check the size of file

From
Pranit Bauva <pranit.bauva@gmail.com>
Date
Jun 8, 2016, 13:08 UTC
Message-ID
<CAFZEwPMiyHqFa0+Z1EAfwG4APcCjJ+1qBeSHjyuOhc6QMb3hLA@mail.gmail.com>
In-Reply-To
<5757D49A.304@web.de>
Hey Torsten,
On Wed, Jun 8, 2016 at 1:47 PM, Torsten Bögershausen <tboegi@web.de> wrote:
Show 65 quoted lines
> On 06/08/2016 09:57 AM, Pranit Bauva wrote:
>>
>> Hey Eric,
>>
>> On Wed, Jun 8, 2016 at 1:07 PM, Eric Sunshine <sunshine@sunshineco.com>
>> wrote:
>>>
>>> On Tue, Jun 7, 2016 at 4:54 PM, Pranit Bauva <pranit.bauva@gmail.com>
>>> wrote:
>>>>
>>>> dir: introduce file_size() to check the size of file
>>>>
>>>> At times we require to see if the file is empty and get the size of the
>>>> file. By using stat we can get the file size without actually having to
>>>> open the file to check for its contents.
>>>
>>> The sole caller of this function in patch 4/4 does so only to check if
>>> the file exists; it doesn't even care about the file's size, thus
>>> neither this function nor this patch seem justified and probably ought
>>> to be dropped unless some better and stronger justification can be
>>> shown.
>>
>> Umm, actually there is a subtle difference between file_exists() and
>> file_size(). file_exists() *only* checks whether the file exists or
>> not while file_size() can also be used to check whether the file is
>> empty or not also see the implementation of both of them which shows
>> the difference. In fact it doesn't care at all about the file size.
>> Now there are a lot of instances in shell scripts where there are
>> quite some differences with -f and -s and some places *do care* about
>> this subtle difference. For eg. in bisect_reset() we test whether the
>> file .git/BISECT_START has some contents in it. But I guess I can add
>> some more justification in the commit message. What do you think?
>>
>>>> Signed-off-by: Pranit Bauva <pranit.bauva@gmail.com>
>>>> ---
>>>> diff --git a/dir.c b/dir.c
>>>> @@ -2036,6 +2036,14 @@ int file_exists(const char *f)
>>>> +ssize_t file_size(const char *filename)
>>>> +{
>>>> +       struct stat st;
>>>> +       if (stat(filename, &st) < 0)
>>>> +               return -1;
>>>> +       return xsize_t(st.st_size);
>>>> +}
>>>> +
>>>> diff --git a/dir.h b/dir.h
>>>> @@ -248,6 +248,13 @@ extern void clear_exclude_list(struct exclude_list
>>>> *el);
>>>> +/*
>>>> + * Return the size of the file `filename`. It returns -1 if error
>>>> + * occurred, 0 if file is empty and a positive number denoting the size
>>>> + * of the file.
>>>> + */
>>>> +extern ssize_t file_size(const char *);
>>
>>
> So what I understand, you want something like this:
>
> +ssize_t file_size_not_zero(const char *filename)
> +{
> +       struct stat st;
> +       if (stat(filename, &st) < 0)
> +               return -1;
> +       return !!st.st_size);
> +}

For the purpose of bisect_reset(), Yes. BTW a similar function exist in builtin/am.c with the name is_empty_file(). But as Christian points out file_size() could help to refactor other parts of code.

Regards, Pranit Bauva

Previous: Torsten BögershausenNext: Torsten Bögershausen
Message 13 of 75 in “bisect--helper: `bisect_clean_state` shell function in C”
  1. 1/4 bisect--helper: `bisect_clean_state` shell function in CPranit Bauva, Jun 7, 2016
  2. 2/4 t6030: explicitly test for bisection cleanupPranit Bauva, Jun 7, 2016
  3. Eric SunshineJun 7, 2016
  4. Pranit BauvaJun 8, 2016
  5. Eric SunshineJun 8, 2016
  6. Pranit BauvaJun 8, 2016
  7. 3/4 dir: introduce file_size() to check the size of filePranit Bauva, Jun 7, 2016
  8. Eric SunshineJun 8, 2016
  9. Pranit BauvaJun 8, 2016
  10. Eric SunshineJun 8, 2016
  11. Christian CouderJun 8, 2016
  12. Torsten BögershausenJun 8, 2016
  13. Pranit BauvaJun 8, 2016
  14. Torsten BögershausenJun 12, 2016
  15. Pranit BauvaJun 13, 2016
  16. 4/4 bisect--helper: `bisect_reset` shell function in CPranit Bauva, Jun 7, 2016
  17. Eric SunshineJun 8, 2016
  18. Christian CouderJun 8, 2016
  19. Christian CouderJun 8, 2016
  20. Eric SunshineJun 8, 2016
  21. Pranit BauvaJun 8, 2016
  22. Eric SunshineJun 8, 2016
  23. Pranit BauvaJun 8, 2016
  24. Eric SunshineJun 7, 2016
  25. Eric SunshineJun 8, 2016
  26. Pranit BauvaJun 8, 2016
  27. Eric SunshineJun 8, 2016
  28. Pranit BauvaJun 8, 2016
  29. Christian CouderJun 8, 2016
  30. Eric SunshineJun 8, 2016
  31. Pranit BauvaJun 8, 2016
  32. 0/6 convert various shell functions in git-bisect to CPranit Bauva, Jun 15, 2016
  33. 1/6 bisect--helper: `bisect_clean_state` shell function in CPranit Bauva, Jun 15, 2016
  34. Eric SunshineJun 15, 2016
  35. Pranit BauvaJun 15, 2016
  36. Eric SunshineJun 15, 2016
  37. 2/6 t6030: explicitly test for bisection cleanupPranit Bauva, Jun 15, 2016
  38. 3/6 wrapper: move is_empty_file() from builtin/am.cPranit Bauva, Jun 15, 2016
  39. Junio C HamanoJun 15, 2016
  40. Pranit BauvaJun 15, 2016
  41. Eric SunshineJun 15, 2016
  42. Pranit BauvaJun 15, 2016
  43. 5/6 bisect--helper: `is_expected_rev` & `check_expected_revs` shell function in CPranit Bauva, Jun 15, 2016
  44. Eric SunshineJun 15, 2016
  45. Pranit BauvaJun 16, 2016
  46. Eric SunshineJun 16, 2016
  47. Pranit BauvaJun 16, 2016
  48. Christian CouderJun 16, 2016
  49. Pranit BauvaJun 17, 2016
  50. 4/6 bisect--helper: `bisect_reset` shell function in CPranit Bauva, Jun 15, 2016
  51. Eric SunshineJun 15, 2016
  52. Pranit BauvaJun 16, 2016
  53. 6/6 bisect--helper: `bisect_write` shell function in CPranit Bauva, Jun 15, 2016
  54. Eric SunshineJun 16, 2016
  55. Pranit BauvaJun 16, 2016
  56. Christian CouderJun 16, 2016
  57. Pranit BauvaJun 17, 2016
  58. Eric SunshineJun 15, 2016
  59. Pranit BauvaJun 15, 2016
  60. 0/6 convert various shell functions in git-bisect to CPranit Bauva, Jun 26, 2016
  61. 1/6 bisect--helper: `bisect_clean_state` shell function in CPranit Bauva, Jun 26, 2016
  62. 2/6 t6030: explicitly test for bisection cleanupPranit Bauva, Jun 26, 2016
  63. 3/6 wrapper: move is_empty_file() and rename it as is_empty_or_missing_file()Pranit Bauva, Jun 26, 2016
  64. 4/6 bisect--helper: `bisect_reset` shell function in CPranit Bauva, Jun 26, 2016
  65. 5/6 bisect--helper: `is_expected_rev` & `check_expected_revs` shell function in CPranit Bauva, Jun 26, 2016
  66. 6/6 bisect--helper: `bisect_write` shell function in CPranit Bauva, Jun 26, 2016
  67. 0/6 convert various shell functions in git-bisect to CPranit Bauva, Jul 6, 2016
  68. 1/6 bisect--helper: `bisect_clean_state` shell function in CPranit Bauva, Jul 6, 2016
  69. 2/6 t6030: explicitly test for bisection cleanupPranit Bauva, Jul 6, 2016
  70. Junio C HamanoJul 11, 2016
  71. 3/6 wrapper: move is_empty_file() and rename it as is_empty_or_missing_file()Pranit Bauva, Jul 6, 2016
  72. 4/6 bisect--helper: `bisect_reset` shell function in CPranit Bauva, Jul 6, 2016
  73. 5/6 bisect--helper: `is_expected_rev` & `check_expected_revs` shell function in CPranit Bauva, Jul 6, 2016
  74. 6/6 bisect--helper: `bisect_write` shell function in CPranit Bauva, Jul 6, 2016
  75. Junio C HamanoJul 11, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.