git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2] refs.h: make all flags arguments unsigned

From
Han-Wen Nienhuys <hanwen@google.com>
Date
Feb 3, 2022, 14:29 UTC
Message-ID
<CAFQ2z_Oxq67XO20oG7Tokk48wm5ZzHRR3GDi4PG5wg7FMJ89aA@mail.gmail.com>
In-Reply-To
<xmqq8ruub35i.fsf@gitster.g>
On Wed, Feb 2, 2022 at 12:03 AM Junio C Hamano <gitster@pobox.com> wrote:
Show 12 quoted lines
>
> Ævar Arnfjörð Bjarmason <avarab@gmail.com> writes:
>
> > The post-image LGTM, but I'm also a bit "meh" on the churn just for
> > signed->unsigned, especially given the conflict with my in-flight
> > ab/no-errno-from-resolve-ref-unsafe. But it's not too bad, and if Junio
> > hasn't complained about it...
>
> I won't complain myself.  I'd still try to help newer developers,
> but my intention is to make it the responsibility for individual
> developers to make sure their topic works well with topics in
> flight ;-)
I'm sending v3 based on seen.
Show 5 quoted lines
> Between "enum" and #define that is stored in "unsigned", neither
> gives us much type safety in C; "enum" may be somewhat worse by
> giving a false sense of having a type safety that does not really
> exist, than "unsigned int" that is more honestly defeats such a
> false sense of safety.  So I have no strong preference either way.

Neither gives true type safety, and I don't know if an enum is kosher at all; shouldn't the value always be one of the enumerees, strictly speaking?

I proposed both options because a distinct typename lets me jump to the definition of the flags easily through ctags.

Another idea is to mark the type of the flags by its name, eg. transaction_flags, resolve_flags, reftype_flags etc. This wouldn't help with ctags, but it does help with readability.

-- 
Han-Wen Nienhuys - Google Munich
I work 80%. Don't expect answers from me on Fridays.
--

Google Germany GmbH, Erika-Mann-Strasse 33, 80636 Munich

Registergericht und -nummer: Hamburg, HRB 86891

Sitz der Gesellschaft: Hamburg

Geschäftsführer: Paul Manicle, Halimah DeLaine Prado
Previous: Junio C HamanoNext: Ævar Arnfjörð Bjarmason
Message 8 of 17 in “refs.h: make all flags arguments unsigned”
  1. refs.h: make all flags arguments unsignedHan-Wen Nienhuys via GitGitGadget, Jan 31, 2022
  2. Junio C HamanoFeb 1, 2022
  3. Han-Wen NienhuysFeb 1, 2022
  4. Junio C HamanoFeb 1, 2022
  5. refs.h: make all flags arguments unsignedHan-Wen Nienhuys via GitGitGadget, Feb 1, 2022
  6. Ævar Arnfjörð BjarmasonFeb 1, 2022
  7. Junio C HamanoFeb 1, 2022
  8. Han-Wen NienhuysFeb 3, 2022
  9. Ævar Arnfjörð BjarmasonFeb 3, 2022
  10. Han-Wen NienhuysFeb 3, 2022
  11. Ævar Arnfjörð BjarmasonFeb 3, 2022
  12. Junio C HamanoFeb 3, 2022
  13. Han-Wen NienhuysFeb 3, 2022
  14. Junio C HamanoFeb 3, 2022
  15. 0/2 refs.h: make all flags arguments unsignedHan-Wen Nienhuys via GitGitGadget, Feb 3, 2022
  16. 1/2 refs.h: make all flags arguments unsignedHan-Wen Nienhuys via GitGitGadget, Feb 3, 2022
  17. 2/2 Uniformize flag argument naming to `flags` or `unused_flags`Han-Wen Nienhuys via GitGitGadget, Feb 3, 2022

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.