Re: [PATCH] Add persistent-https to contrib
- From
Colby Ranger <cranger@google.com>
- Date
- May 29, 2012, 21:29 UTC
- Message-ID
- <CAFFbUKJz=-KdNJSgqwkaBNAL6gyBzjxCkVjKgAmHQ7ztzGh=UA@mail.gmail.com>
- In-Reply-To
- <7vlikhwbdc.fsf@alter.siamese.dyndns.org>
Show 5 quoted lines
> I do not mind carrying this in the contrib/ area (I am assuming that > distributing Apache licensed software that does not link with GPLv2 core > is OK). It may be just me, but a file called COPYING that does not have > GPL text in it was a bit surprising. I wonder if it is more customary to > call it either LICENSE (or perhaps LICENSE-2.0)?
Agreed. I'll change the name to LICENSE.
> It might deserve its own contrib/persistent-https/Makefile in addition to > your internal "release" scripts, though.
OK. I'll update the code to use a simple Makefile for everything, instead of the shell scripts.
Show 10 quoted lines
> More specifically, this environment variable is a way to tell the wrapped > helper who is wrapping it. Users outside Google's environment of the > persistent-https helper obviously would not care about the corporate > sanitary sewer overflow mechanism, but they may have a similar need to > tweak what happens inside the git-remote-http that is driven by the > persistent helper. They would not care about "we can enable corpsso", but > they would benefit from knowing that either: > > (1) the connection is "secure" (by the definition above); or > (2) the connection is going to this particular helper.
Agreed, I'll go with approach (1) and change the name of the var to be GIT_PERSISTENT_HTTPS_SECURE. Also, I will update the code to remove any GIT_PERSISTENT_HTTPS_SECURE from the environment.