Re: [PATCH] receive-pack: purge temporary data if no command is ready to run
- From
Bojun Chen <bojun.cbj@gmail.com>
- Date
- Jan 25, 2022, 16:49 UTC
- Message-ID
- <CADuS7Aov-J4LjAm_e_DOHaAba9JHFFV-2trxBywzL4vtwuvr4Q@mail.gmail.com>
- In-Reply-To
- <xmqqk0eo1zhu.fsf@gitster.g>
Junio C Hamano <gitster@pobox.com> 于2022年1月25日周二 07:32写道:
Show 14 quoted lines
> > > + /* > > + * If there is no command ready to run, should return directly to destroy > > + * temporary data in the quarantine area. > > + */ > > + for (cmd = commands; cmd && cmd->error_string; cmd = cmd->next); > > Write the empty body of the loop like this: > > for (...) > ; /* nothing */ > > to make it stand out. >
Thanks for the suggestion, this is more readable.
Show 27 quoted lines
> > + if (!cmd)
> > + return;
> > +
>
> > -mk_empty () {
> > +mk_empty() {
> > repo_name="$1"
> > rm -fr "$repo_name" &&
> > - mkdir "$repo_name" &&
> > - (
> > - cd "$repo_name" &&
> > - git init &&
> > - git config receive.denyCurrentBranch warn &&
> > - mv .git/hooks .git/hooks-disabled
> > - )
> > + mkdir "$repo_name" &&
> > + (
> > + cd "$repo_name" &&
> > + git init &&
> > + git config receive.denyCurrentBranch warn &&
> > + mv .git/hooks .git/hooks-disabled
> > + )
> > }
>
> Documentation/CodingGuidelines. As far as I can tell, the above
> does not change anything the function does, and the only change in
> the patch is to violate the style guide badly. Why?Sorry. I'll roll back these formatting issues. Jiang Xin reminded me to look at this document, but I did miss an important part. At the same time, I used a wrong range-diff command in the review I sent internally earlier, which made my changes look like "mk_empty() {" to "mk_empty () {". So this problem was not detected in time.