Re: [PATCH v3 0/3] Add "git rebase --show-current-patch"
- From
Duy Nguyen <pclouds@gmail.com>
- Date
- Feb 23, 2018, 10:20 UTC
- Message-ID
- <CACsJy8DefOL=JS-24GBucGfUx5q3A=JoLVq2N6ykdtz4yQ-dmA@mail.gmail.com>
- In-Reply-To
- <87h8q97sim.fsf@passepartout.tim-landscheidt.de>
On Thu, Feb 22, 2018 at 7:54 AM, Tim Landscheidt <tim@tim-landscheidt.de> wrote:
Show 25 quoted lines
> Junio C Hamano <gitster@pobox.com> wrote: > >>> Compared to v2: > >>> - the potential loss of errno before it's printed out in builtin/am.c >>> is fixed. >>> - keep update_ref() in sequencer.c non-fatal like this rest >>> - rename ORIG_COMMIT to REBASE_HEAD > >>> Interdiff: > >> This round hasn't seen any comments. Is everybody happy with it? > >> I personally do not have strong opinion for the feature but didn't >> spot anything against the execution, either, so... > > Sorry for the late reply: I dislike REBASE_/HEAD/ because > ORIG_/HEAD/ refers to the tip of the original branch, and > /ORIG/_HEAD refers to the original branch, so > /REBASE/_/HEAD/ is doubly confusing IMHO. I consider > ORIG_COMMIT easier to understand because ORIG_HEAD refers to > the tip of the original branch, and ORIG_COMMIT would refer > to one of the commits making up that original branch, but as > I suggested it myself I might not be very objective in that > regard :-).
I wonder if you could make a ref symlink named ORIG_COMMIT pointing to REBASE_HEAD. A bit more setup for you, but that'll make everybody happy.
-- Duy