Re: [PATCH v2 3/3] rebase: introduce and use pseudo-ref ORIG_COMMIT
- From
Duy Nguyen <pclouds@gmail.com>
- Date
- Feb 1, 2018, 10:02 UTC
- Message-ID
- <CACsJy8D8PaDR0r+6AKMgPo9UBcWYQC8goaVkVhxMCXCa1E9F9A@mail.gmail.com>
- In-Reply-To
- <xmqqlggdr519.fsf@gitster-ct.c.googlers.com>
On Thu, Feb 1, 2018 at 6:18 AM, Junio C Hamano <gitster@pobox.com> wrote:
Show 19 quoted lines
> Nguyễn Thái Ngọc Duy <pclouds@gmail.com> writes: > >> The new command `git rebase --show-current-patch` is useful for seeing >> the commit related to the current rebase state. Some however may find >> the "git show" command behind it too limiting. You may want to >> increase context lines, do a diff that ignores whitespaces... >> >> For these advanced use cases, the user can execute any command they >> want with the new pseudo ref ORIG_COMMIT. >> >> This also helps show where the stopped commit is from, which is hard >> to see from the previous patch which implements --show-current-patch. >> >> Helped-by: Tim Landscheidt <tim@tim-landscheidt.de> >> Signed-off-by: Nguyễn Thái Ngọc Duy <pclouds@gmail.com> >> --- > > Hmph, how is this new file conceptually different from existing ones > like CHERRY_PICK_HEAD?
Conceptually the same, except that CHERRY_PICK_HEAD can't be reused because it's specifically tied to git-cherry-pick (there's even code that delete this ref if cherry-pick is run as part of rebase, and git-status uses this ref to see if a cherry-pick is in progress). There's also REVERT_HEAD in sequencer.c, same purpose but for git-revert. Perhaps I should rename this new ref to REBASE_HEAD to follow the same naming?
-- Duy