Re: [PATCH v2 5/6] Add new @ shortcut for HEAD
- From
Duy Nguyen <pclouds@gmail.com>
- Date
- May 1, 2013, 02:03 UTC
- Message-ID
- <CACsJy8D_-S_BvQAa5b2+XpfM2-fJcEQ5EJa4RRtV1vQPEe1emA@mail.gmail.com>
- In-Reply-To
- <1367358554-4257-6-git-send-email-felipe.contreras@gmail.com>
On Wed, May 1, 2013 at 4:49 AM, Felipe Contreras <felipe.contreras@gmail.com> wrote:
Show 11 quoted lines
> So HEAD@{0}~0^0 is too much to type, but we can remove '^0', and we can
> remove '~0', and we can remove 'HEAD', which leaves us with @{0}, but we
> can't remove '{0}'?
>
> This patch allows '@' to be the same as 'HEAD'.
>
> So now we can use 'git show @~1', and all that goody goodness.
>
> Until now '@' was a valid name, but it conflicts with this idea, so lets
> make it invalid. Very few people if any probably used this name, if they
> did, they can rename it by using the full-path (e.g. refs/heads/@).People can write master short for refs/heads/master, but can't with refs/heads/@. Would it be better to detect if dwim_ref("@") exists, then disable special '@' and warn user to rename '@' to something else? After they have renamed it, make '@' special and forbid it in any component in the ref (i.e. refs/heads/@ is forbidden too). -- Duy