Re: [PATCH 19/20] Rename sha1_array to oid_array
- From
Duy Nguyen <pclouds@gmail.com>
- Date
- Mar 20, 2017, 12:25 UTC
- Message-ID
- <CACsJy8B1HhSWBMThoiy_F2s3T62nwNAO-Hd9E+d9k82Y=Ku+FA@mail.gmail.com>
- In-Reply-To
- <20170318211954.564030-20-sandals@crustytoothpaste.net>
On Sun, Mar 19, 2017 at 4:19 AM, brian m. carlson <sandals@crustytoothpaste.net> wrote:
Show 11 quoted lines
> Since this structure handles an array of object IDs, rename it to struct > oid_array. Also rename the accessor functions and the initialization > constant. > > This commit was produced mechanically by providing non-Documentation > files to the following Perl one-liners: > > perl -pi -E 's/struct sha1_array/struct oid_array/g' > perl -pi -E 's/\bsha1_array_/oid_array_/g' > perl -pi -E 's/SHA1_ARRAY_INIT/OID_ARRAY_INIT/g' >
I see a few multi-line function calls become unaligned because oid_array is one character shorter than sha1_array. But I'm ok with that, no need to manually align them. We can fix those when we touch neighbor code.
-- Duy