Re: [PATCH 19/20] Rename sha1_array to oid_array
- From
brian m. carlson <sandals@crustytoothpaste.net>
- Date
- Mar 21, 2017, 00:54 UTC
- Message-ID
- <20170321005416.l4c5sdbcnf5wm46h@genre.crustytoothpaste.net>
- In-Reply-To
- <CACsJy8B1HhSWBMThoiy_F2s3T62nwNAO-Hd9E+d9k82Y=Ku+FA@mail.gmail.com>
On Mon, Mar 20, 2017 at 07:25:25PM +0700, Duy Nguyen wrote:
Show 18 quoted lines
> On Sun, Mar 19, 2017 at 4:19 AM, brian m. carlson > <sandals@crustytoothpaste.net> wrote: > > Since this structure handles an array of object IDs, rename it to struct > > oid_array. Also rename the accessor functions and the initialization > > constant. > > > > This commit was produced mechanically by providing non-Documentation > > files to the following Perl one-liners: > > > > perl -pi -E 's/struct sha1_array/struct oid_array/g' > > perl -pi -E 's/\bsha1_array_/oid_array_/g' > > perl -pi -E 's/SHA1_ARRAY_INIT/OID_ARRAY_INIT/g' > > > > I see a few multi-line function calls become unaligned because > oid_array is one character shorter than sha1_array. But I'm ok with > that, no need to manually align them. We can fix those when we touch > neighbor code.
That's how I felt about the situation: basically, people would appreciate the ease of review over the tidiness of the code.
-- brian m. carlson / brian with sandals: Houston, Texas, US +1 832 623 2791 | https://www.crustytoothpaste.net/~bmc | My opinion only OpenPGP: https://keybase.io/bk2204