Re: [PATCH 1/2] checkout_entry(): use the strbuf throughout the function
- From
Duy Nguyen <pclouds@gmail.com>
- Date
- Mar 13, 2014, 11:22 UTC
- Message-ID
- <CACsJy8AG5T4sA6j0AGtkX2uhVNDvppT=tnNrQNuZ1rhHKArP0w@mail.gmail.com>
- In-Reply-To
- <1394702348-6433-2-git-send-email-mhagger@alum.mit.edu>
On Thu, Mar 13, 2014 at 4:19 PM, Michael Haggerty <mhagger@alum.mit.edu> wrote:
> There is no need to break out the "buf" and "len" members into > separate temporary variables. Rename path_buf to path and use > path.buf and path.len directly. This makes it easier to reason about > the data flow in the function.
I wanted to keep changes to minimum when I did that. But I guess it has its downside as you found out.
-- Duy