From: Duy Nguyen Date: Thu, 13 Mar 2014 11:22:31 GMT Subject: Re: [PATCH 1/2] checkout_entry(): use the strbuf throughout the function Message-ID: In-Reply-To: <1394702348-6433-2-git-send-email-mhagger@alum.mit.edu> On Thu, Mar 13, 2014 at 4:19 PM, Michael Haggerty wrote: > There is no need to break out the "buf" and "len" members into > separate temporary variables. Rename path_buf to path and use > path.buf and path.len directly. This makes it easier to reason about > the data flow in the function. I wanted to keep changes to minimum when I did that. But I guess it has its downside as you found out. -- Duy