git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 18/20] builtin/am: convert to struct object_id

From
Paul Tan <pyokagan@gmail.com>
Date
Aug 29, 2016, 07:02 UTC
Message-ID
<CACRoPnQvdq3xaRF9niU-b0qLxVCvmbpv2_roxUaEaDFftt7_wQ@mail.gmail.com>
In-Reply-To
<20160828232757.373278-19-sandals@crustytoothpaste.net>
Hi Brian,

On Mon, Aug 29, 2016 at 7:27 AM, brian m. carlson <sandals@crustytoothpaste.net> wrote:

> Signed-off-by: brian m. carlson <sandals@crustytoothpaste.net>
> ---
>  builtin/am.c | 138 +++++++++++++++++++++++++++++------------------------------
>  1 file changed, 69 insertions(+), 69 deletions(-)

I looked through this patch, and the conversion looks faithful and straightforward to me. Just two minor comments:

Show 16 quoted lines
> diff --git a/builtin/am.c b/builtin/am.c
> index 739b34dc..632d4288 100644
> --- a/builtin/am.c
> +++ b/builtin/am.c
> @@ -1053,10 +1053,10 @@ static void am_setup(struct am_state *state, enum patch_format patch_format,
>         else
>                 write_state_text(state, "applying", "");
>
> -       if (!get_sha1("HEAD", curr_head)) {
> -               write_state_text(state, "abort-safety", sha1_to_hex(curr_head));
> +       if (!get_oid("HEAD", &curr_head)) {
> +               write_state_text(state, "abort-safety", oid_to_hex(&curr_head));
>                 if (!state->rebasing)
> -                       update_ref("am", "ORIG_HEAD", curr_head, NULL, 0,
> +                       update_ref("am", "ORIG_HEAD", curr_head.hash, NULL, 0,
>                                         UPDATE_REFS_DIE_ON_ERR);

I noticed that you used update_ref_oid() in other places of this patch. Perhaps this should use update_ref_oid() as well for consistency?

Show 9 quoted lines
> @@ -1665,9 +1665,8 @@ static int fall_back_threeway(const struct am_state *state, const char *index_pa
>   */
>  static void do_commit(const struct am_state *state)
>  {
> -       unsigned char tree[GIT_SHA1_RAWSZ], parent[GIT_SHA1_RAWSZ],
> -                     commit[GIT_SHA1_RAWSZ];
> -       unsigned char *ptr;
> +       struct object_id tree, parent, commit;
> +       struct object_id *ptr;

Ah, I just noticed that this is a very poorly named variable. Whoops. Since we are here, should we rename this to something like "old_oid"? Also, this should probably be a "const struct object_id *" as well, I think.

Thanks, Paul

Previous: brian m. carlsonNext: brian m. carlson
Message 10 of 30 in “object_id part 5”
  1. 00/20 object_id part 5brian m. carlson, Aug 28, 2016
  2. 02/20 builtin/apply: convert static functions to struct object_idbrian m. carlson, Aug 28, 2016
  3. 07/20 builtin: convert textconv_object to use struct object_idbrian m. carlson, Aug 28, 2016
  4. 01/20 cache: convert struct cache_entry to use struct object_idbrian m. carlson, Aug 28, 2016
  5. Johannes SchindelinAug 29, 2016
  6. Jakub NarębskiAug 29, 2016
  7. Johannes SchindelinAug 29, 2016
  8. brian m. carlsonAug 29, 2016
  9. 18/20 builtin/am: convert to struct object_idbrian m. carlson, Aug 28, 2016
  10. Paul TanAug 29, 2016
  11. brian m. carlsonAug 29, 2016
  12. 06/20 builtin/cat-file: convert some static functions to struct object_idbrian m. carlson, Aug 28, 2016
  13. 17/20 refs: add an update_ref_oid function.brian m. carlson, Aug 28, 2016
  14. 03/20 builtin/blame: convert struct origin to use struct object_idbrian m. carlson, Aug 28, 2016
  15. 16/20 sha1_name: convert get_sha1_mb to struct object_idbrian m. carlson, Aug 28, 2016
  16. 19/20 builtin/commit-tree: convert to struct object_idbrian m. carlson, Aug 28, 2016
  17. 05/20 builtin/cat-file: convert struct expand_data to use struct object_idbrian m. carlson, Aug 28, 2016
  18. 20/20 builtin/reset: convert to use struct object_idbrian m. carlson, Aug 28, 2016
  19. Johannes SchindelinAug 31, 2016
  20. 04/20 builtin/log: convert some static functions to use struct object_idbrian m. carlson, Aug 28, 2016
  21. 13/20 builtin/rm: convert to use struct object_idbrian m. carlson, Aug 28, 2016
  22. 12/20 builtin/blame: convert file to use struct object_idbrian m. carlson, Aug 28, 2016
  23. 11/20 Convert read_mmblob to take struct object_id.brian m. carlson, Aug 28, 2016
  24. 14/20 notes: convert init_notes to use struct object_idbrian m. carlson, Aug 28, 2016
  25. 15/20 builtin/update-index: convert file to struct object_idbrian m. carlson, Aug 28, 2016
  26. 09/20 builtin/checkout: convert some static functions to struct object_idbrian m. carlson, Aug 28, 2016
  27. 08/20 streaming: make stream_blob_to_fd take struct object_idbrian m. carlson, Aug 28, 2016
  28. Johannes SchindelinAug 29, 2016
  29. 10/20 notes-merge: convert struct notes_merge_pair to struct object_idbrian m. carlson, Aug 28, 2016
  30. Johannes SchindelinAug 31, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.