git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 10/11] push: flip !triangular for centralized

From
Elijah Newren <newren@gmail.com>
Date
May 28, 2021, 21:05 UTC
Message-ID
<CABPp-BHs_id3kOHgBWCK0QjviuRu7Dgbq5iB7z5=RZDOX-ontA@mail.gmail.com>
In-Reply-To
<20210528201014.2175179-11-felipe.contreras@gmail.com>

On Fri, May 28, 2021 at 1:10 PM Felipe Contreras <felipe.contreras@gmail.com> wrote:

>
> Git is a *distributed* version control system, centralized workflows are
> the uncommon case, where we do need to do extra checks.

The commit message seemed slightly funny to me, though I'm not sure why. However...

Show 72 quoted lines
> Signed-off-by: Felipe Contreras <felipe.contreras@gmail.com>
> ---
>  builtin/push.c | 16 ++++++++--------
>  1 file changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/builtin/push.c b/builtin/push.c
> index 8ecfbe8d63..1856f62861 100644
> --- a/builtin/push.c
> +++ b/builtin/push.c
> @@ -186,7 +186,7 @@ static const char message_detached_head_die[] =
>            "    git push %s HEAD:<name-of-remote-branch>\n");
>
>  static void setup_push_upstream(struct remote *remote, struct branch *branch,
> -                               int triangular)
> +                               int centralized)
>  {
>         if (!branch)
>                 die(_(message_detached_head_die), remote->name);
> @@ -201,7 +201,7 @@ static void setup_push_upstream(struct remote *remote, struct branch *branch,
>         if (branch->merge_nr != 1)
>                 die(_("The current branch %s has multiple upstream branches, "
>                     "refusing to push."), branch->name);
> -       if (triangular)
> +       if (!centralized)
>                 die(_("You are pushing to remote '%s', which is not the upstream of\n"
>                       "your current branch '%s', without telling me what to push\n"
>                       "to update which remote branch."),
> @@ -210,12 +210,12 @@ static void setup_push_upstream(struct remote *remote, struct branch *branch,
>         refspec_appendf(&rs, "%s:%s", branch->refname, branch->merge[0]->src);
>  }
>
> -static void setup_push_simple(struct remote *remote, struct branch *branch, int triangular)
> +static void setup_push_simple(struct remote *remote, struct branch *branch, int centralized)
>  {
>         if (!branch)
>                 die(_(message_detached_head_die), remote->name);
>
> -       if (!triangular) {
> +       if (centralized) {
>                 if (!branch->merge_nr || !branch->merge || !branch->remote_name)
>                         die(_("The current branch %s has no upstream branch.\n"
>                             "To push the current branch and set the remote as upstream, use\n"
> @@ -238,7 +238,7 @@ static void setup_push_simple(struct remote *remote, struct branch *branch, int
>  static void setup_default_push_refspecs(struct remote *remote)
>  {
>         struct branch *branch = branch_get(NULL);
> -       int triangular = remote != remote_get(NULL);
> +       int centralized = remote == remote_get(NULL);
>
>         switch (push_default) {
>         default:
> @@ -248,15 +248,15 @@ static void setup_default_push_refspecs(struct remote *remote)
>
>         case PUSH_DEFAULT_UNSPECIFIED:
>         case PUSH_DEFAULT_SIMPLE:
> -               setup_push_simple(remote, branch, triangular);
> +               setup_push_simple(remote, branch, centralized);
>                 break;
>
>         case PUSH_DEFAULT_UPSTREAM:
> -               setup_push_upstream(remote, branch, triangular);
> +               setup_push_upstream(remote, branch, centralized);
>                 break;
>
>         case PUSH_DEFAULT_CURRENT:
> -               setup_push_simple(remote, branch, 1);
> +               setup_push_simple(remote, branch, 0);
>                 break;
>
>         case PUSH_DEFAULT_NOTHING:
> --
> 2.32.0.rc0

...I think the code is slightly easier to read and reason about since it removes the double negative. In particular, when someone reading the code sees !triangular, and doesn't know or remember the meaning, they have to translate that to !(remote != remote_get(NULL)). centralized and !centralized do not have that same problem. So, I like the newer version.

Previous: Felipe ContrerasNext: Felipe Contreras
Message 20 of 24 in “Unconvolutize push.default=simple”
  1. 00/11 Unconvolutize push.default=simpleFelipe Contreras, May 28, 2021
  2. 01/11 push: hedge code of default=simpleFelipe Contreras, May 28, 2021
  3. 02/11 push: move code to setup_push_simple()Felipe Contreras, May 28, 2021
  4. 03/11 push: reorganize setup_push_simple()Felipe Contreras, May 28, 2021
  5. Elijah NewrenMay 28, 2021
  6. Felipe ContrerasMay 28, 2021
  7. Elijah NewrenMay 28, 2021
  8. 04/11 push: simplify setup_push_simple()Felipe Contreras, May 28, 2021
  9. Elijah NewrenMay 28, 2021
  10. Felipe ContrerasMay 28, 2021
  11. 05/11 push: remove unused code in setup_push_upstream()Felipe Contreras, May 28, 2021
  12. 06/11 push: merge current and simpleFelipe Contreras, May 28, 2021
  13. 07/11 push: remove redundant checkFelipe Contreras, May 28, 2021
  14. 08/11 push: fix Yoda conditionFelipe Contreras, May 28, 2021
  15. 09/11 push: remove trivial functionFelipe Contreras, May 28, 2021
  16. 11/11 doc: push: explain default=simple correctlyFelipe Contreras, May 28, 2021
  17. Elijah NewrenMay 28, 2021
  18. Bagas SanjayaMay 29, 2021
  19. 10/11 push: flip !triangular for centralizedFelipe Contreras, May 28, 2021
  20. Elijah NewrenMay 28, 2021
  21. Felipe ContrerasMay 28, 2021
  22. Elijah NewrenMay 28, 2021
  23. Felipe ContrerasMay 28, 2021
  24. Elijah NewrenMay 28, 2021

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.