git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 3/6] t6423: document two bugs with rename-to-self testcases

From
Elijah Newren <newren@gmail.com>
Date
Aug 4, 2025, 19:15 UTC
Message-ID
<CABPp-BEUFaePoJx-dn9hOE6r7mQV_W_6QF2K1sJJ2uXeL81rdg@mail.gmail.com>
In-Reply-To
<aIx7OEX6AEqNsIHb@pks.im>
On Fri, Aug 1, 2025 at 1:31 AM Patrick Steinhardt <ps@pks.im> wrote:
Show 14 quoted lines
>
> On Tue, Jul 22, 2025 at 03:23:08PM +0000, Elijah Newren via GitGitGadget wrote:
> > diff --git a/t/t6423-merge-rename-directories.sh b/t/t6423-merge-rename-directories.sh
> > index f48ed6d03534..69de7a3b84af 100755
> > --- a/t/t6423-merge-rename-directories.sh
> > +++ b/t/t6423-merge-rename-directories.sh
> > @@ -5092,7 +5111,85 @@ test_expect_success '12n: Directory rename transitively makes rename back to sel
> >               git checkout -q B^0 &&
> >
> >               test_must_fail git cherry-pick A^0 >out &&
> > -             grep "CONFLICT (file location).*should perhaps be moved" out
> > +             grep "CONFLICT (file location).*should perhaps be moved" out &&
>
> Let's use `test_grep` while at it.

Oh, right, it was test_i18ngrep that we weren't supposed to use. Yeah, I can switch over to test_grep.

Show 29 quoted lines
> [snip]
> > +test_expect_failure '12n2: Directory rename transitively makes rename back to self' '
> > +     test_setup_12n2 &&
> > +     (
> > +             cd 12n2 &&
> > +
> > +             git checkout -q B^0 &&
> > +
> > +             # NOTE: Since merge.directoryRenames=true, there is no path
> > +             # conflict for world vs. tools/world; it should end up at
> > +             # world.  The fact that world was unmodified on side A, means
> > +             # there was no content conflict; we should just take the
> > +             # content from side B -- i.e. delete the file.  So merging
> > +             # could just delete world.
> > +             #
> > +             # However, rename-to-self-via-directory-rename is a bit more
> > +             # challenging.  Relax this test to allow world to be treated
> > +             # as a modify/delete conflict as well.
> > +
> > +             test_might_fail git -c merge.directoryRenames=true merge A^0 >out &&
> > +
> > +             # Should have 1 entry for hello, and either 0 or 2 for world
> > +             test_stdout_line_count = 1 git ls-files -s hello &&
> > +             test_stdout_line_count != 1 git ls-files -s world &&
> > +             if test_stdout_line_count != 0 git ls-files -s world
> > +             then
> > +                     grep "CONFLICT (modify/delete).*world deleted in HEAD" out
>
> Here, as well.
Will do.
Show 9 quoted lines
> > +             fi
> >       )
> >  '
>
> I found it to be a bit weird that we have this conditional here.
> Shouldn't we expect one particular outcome? Even if multiple outcomes
> would be techincally correct I think we should expect one particular
> result, but we may add a comment to explain that different output would
> be fine, too.
Isn't that exactly what I did, with the note I'll copy below?
Show 10 quoted lines
> > +             # NOTE: Since merge.directoryRenames=true, there is no path
> > +             # conflict for world vs. tools/world; it should end up at
> > +             # world.  The fact that world was unmodified on side A, means
> > +             # there was no content conflict; we should just take the
> > +             # content from side B -- i.e. delete the file.  So merging
> > +             # could just delete world.
> > +             #
> > +             # However, rename-to-self-via-directory-rename is a bit more
> > +             # challenging.  Relax this test to allow world to be treated
> > +             # as a modify/delete conflict as well.
Previous: Patrick SteinhardtNext: Patrick Steinhardt
Message 6 of 39 in “Fix various rename corner cases”
  1. 0/6 Fix various rename corner casesElijah Newren via GitGitGadget, Jul 22, 2025
  2. 1/6 merge-ort: update comments to modern testfile locationElijah Newren via GitGitGadget, Jul 22, 2025
  3. 2/6 merge-ort: drop unnecessary temporary in check_for_directory_rename()Elijah Newren via GitGitGadget, Jul 22, 2025
  4. 3/6 t6423: document two bugs with rename-to-self testcasesElijah Newren via GitGitGadget, Jul 22, 2025
  5. Patrick SteinhardtAug 1, 2025
  6. Elijah NewrenAug 4, 2025
  7. Patrick SteinhardtAug 5, 2025
  8. Elijah NewrenAug 5, 2025
  9. 4/6 t6423: fix missed staging of file in testcases 12i,12j,12kElijah Newren via GitGitGadget, Jul 22, 2025
  10. Patrick SteinhardtAug 1, 2025
  11. Elijah NewrenAug 4, 2025
  12. Patrick SteinhardtAug 5, 2025
  13. Elijah NewrenAug 5, 2025
  14. 5/6 merge-ort: fix incorrect file handlingElijah Newren via GitGitGadget, Jul 22, 2025
  15. Patrick SteinhardtAug 1, 2025
  16. Elijah NewrenAug 4, 2025
  17. Patrick SteinhardtAug 5, 2025
  18. Elijah NewrenAug 5, 2025
  19. 6/6 merge-ort: fix directory rename on top of source of other rename/deleteElijah Newren via GitGitGadget, Jul 22, 2025
  20. Patrick SteinhardtAug 1, 2025
  21. Elijah NewrenAug 4, 2025
  22. Patrick SteinhardtAug 1, 2025
  23. 0/6 Fix various rename corner casesElijah Newren via GitGitGadget, Aug 5, 2025
  24. 1/6 merge-ort: update comments to modern testfile locationElijah Newren via GitGitGadget, Aug 5, 2025
  25. 2/6 merge-ort: drop unnecessary temporary in check_for_directory_rename()Elijah Newren via GitGitGadget, Aug 5, 2025
  26. 3/6 t6423: document two bugs with rename-to-self testcasesElijah Newren via GitGitGadget, Aug 5, 2025
  27. 4/6 t6423: fix missed staging of file in testcases 12i,12j,12kElijah Newren via GitGitGadget, Aug 5, 2025
  28. 5/6 merge-ort: fix incorrect file handlingElijah Newren via GitGitGadget, Aug 5, 2025
  29. 6/6 merge-ort: fix directory rename on top of source of other rename/deleteElijah Newren via GitGitGadget, Aug 5, 2025
  30. Junio C HamanoAug 5, 2025
  31. Elijah NewrenAug 5, 2025
  32. 0/7 Fix various rename corner casesElijah Newren via GitGitGadget, Aug 6, 2025
  33. 1/7 merge-ort: update comments to modern testfile locationElijah Newren via GitGitGadget, Aug 6, 2025
  34. 2/7 merge-ort: drop unnecessary temporary in check_for_directory_rename()Elijah Newren via GitGitGadget, Aug 6, 2025
  35. 3/7 t6423: document two bugs with rename-to-self testcasesElijah Newren via GitGitGadget, Aug 6, 2025
  36. 4/7 t6423: fix missed staging of file in testcases 12i,12j,12kElijah Newren via GitGitGadget, Aug 6, 2025
  37. 5/7 merge-ort: clarify the interning of strings in opt->priv->pathElijah Newren via GitGitGadget, Aug 6, 2025
  38. 6/7 merge-ort: fix incorrect file handlingElijah Newren via GitGitGadget, Aug 6, 2025
  39. 7/7 merge-ort: fix directory rename on top of source of other rename/deleteElijah Newren via GitGitGadget, Aug 6, 2025

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.