git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 2/3] submodule-config: rename commit_sha1 to commit_or_tree

From
Jacob Keller <jacob.keller@gmail.com>
Date
Nov 3, 2016, 05:36 UTC
Message-ID
<CA+P7+xo_2AHx8c7iCkaGeMCH4WynM=6eTOG0arfcBdex-AahCw@mail.gmail.com>
In-Reply-To
<20161102231722.15787-3-sbeller@google.com>
On Wed, Nov 2, 2016 at 4:17 PM, Stefan Beller <sbeller@google.com> wrote:
Show 5 quoted lines
> -`const struct submodule *submodule_from_path(const unsigned char *commit_sha1, const char *path)`::
> +`const struct submodule *submodule_from_path(const unsigned char *commit_or_tree, const char *path)`::
>
>         Lookup values for one submodule by its commit_sha1 and path.
>
Update the doc text here as well?

Thanks, Jake

Previous: Stefan Beller
Message 5 of 5 in “submodule-config: clarify/cleanup docs and header”
  1. 0/3 submodule-config: clarify/cleanup docs and headerStefan Beller, Nov 2, 2016
  2. 1/3 submodule config: inline config_from_{name, path}Stefan Beller, Nov 2, 2016
  3. 3/3 submodule-config: clarify parsing of null_sha1 elementStefan Beller, Nov 2, 2016
  4. 2/3 submodule-config: rename commit_sha1 to commit_or_treeStefan Beller, Nov 2, 2016
  5. Jacob KellerNov 3, 2016

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.