Re: [OUTREACHY][PATCH v2] t7006: Use test_path_is_* functions in test script
- From
- Joey Salazar <jgsal@protonmail.com>
- Date
- Oct 26, 2020, 23:00 UTC
- Message-ID
- <AwF-WVCPGK9qyy3lWQ-aYXuvw7HTPjjGuvT4rbPjgoWZE0czToIU-aACj2oyRnkOevGWLQbDgtndt9dkMSGF-SFkNanPgao9yLuVYU1VURI=@protonmail.com>
- In-Reply-To
- <20201026220228.GD2645313@google.com>
On Monday, October 26, 2020 4:02 PM, Jonathan Nieder <jrnieder@gmail.com> wrote:
Show 5 quoted lines
> (administrivia: the convention on this mailing list is not to top-post. > When your mailer puts the cursor at the top of the reply, that's a > signal to go through and delete the parts you don't want to reply to, > before putting your reply below the bit you do want to reply to) >
Understood, thank you.
Show 5 quoted lines
> Thanks, Joey. I think we'd prefer a v3 since that gives you a place > to put the commit message for the combined patch. > > Or if you prefer for Junio to take care of the squashing, an > alternative is to write the proposed commit message here.
I've locally incorporated the changes and remain open to either option. The proposed amended commit message would be; Modernize the test by replacing `test -e` instances with `test_path_is_file` helper functions, and `! test -e` with `test_path_is_missing`, for better readability and diagnostic messages. For instances when `${if_local_config}` is either '' or '! ' then `test_path_is_file` will diagnose the directory and print a message if and only if the result `is false` goes away.
Signed-off-by: Joey Salazar <jgsal@protonmail.com>
Does this capture the idea correctly?
> Thanks for your patient work, > Jonathan
Thank you for all your input and guidance.