git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] unpack_trees(): skip trees that are the same in all input

From
Nguyen Thai Ngoc Duy <pclouds@gmail.com>
Date
Dec 30, 2010, 12:44 UTC
Message-ID
<AANLkTinWj7vjQcJVZ732HDj++F8PjUHhne8unoORsVB9@mail.gmail.com>
In-Reply-To
<7vd3oktmoo.fsf@alter.siamese.dyndns.org>
On Thu, Dec 30, 2010 at 2:15 AM, Junio C Hamano <gitster@pobox.com> wrote:
Show 6 quoted lines
> By the way, I think info->data->skip_sparse_checkout should be fixed by
> renaming it to info->data->sparse_checkout.  The flag controls a special
> case logic that should not be in effect unless explicitly asked, and
> forcing normal codepath to say "If skip_sparse_checkout is not false, do
> this" in double-negative is unnice than "If sparse_checkout is in effect,
> please run this special case" when reading the code.

It's something to do with zero value being "feature set by default". Unless explicitly said otherwise, sparse checkout code should be in effect so that skip-checkout bit is preserved in index. No, double negation is not nice. But I don't know how I can set unpack_trees_options.sparse_checkout = 1 by default.

-- 
Duy
Previous: Junio C Hamano
Message 4 of 4 in “unpack_trees(): skip trees that are the same in all input”
  1. unpack_trees(): skip trees that are the same in all inputJunio C Hamano, Dec 22, 2010
  2. Nguyen Thai Ngoc DuyDec 29, 2010
  3. Junio C HamanoDec 29, 2010
  4. Nguyen Thai Ngoc DuyDec 30, 2010

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.