From: Nguyen Thai Ngoc Duy Date: Thu, 30 Dec 2010 12:44:08 GMT Subject: Re: [PATCH] unpack_trees(): skip trees that are the same in all input Message-ID: In-Reply-To: <7vd3oktmoo.fsf@alter.siamese.dyndns.org> On Thu, Dec 30, 2010 at 2:15 AM, Junio C Hamano wrote: > By the way, I think info->data->skip_sparse_checkout should be fixed by > renaming it to info->data->sparse_checkout.  The flag controls a special > case logic that should not be in effect unless explicitly asked, and > forcing normal codepath to say "If skip_sparse_checkout is not false, do > this" in double-negative is unnice than "If sparse_checkout is in effect, > please run this special case" when reading the code. It's something to do with zero value being "feature set by default". Unless explicitly said otherwise, sparse checkout code should be in effect so that skip-checkout bit is preserved in index. No, double negation is not nice. But I don't know how I can set unpack_trees_options.sparse_checkout = 1 by default. -- Duy