git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 2/2] gitweb: introduce localtime feature

From
Kevin Cernekee <cernekee@gmail.com>
Date
Mar 19, 2011, 21:22 UTC
Message-ID
<AANLkTikw7_9Q0MgVZZxX_dXvcxoXfx5VEmRQkVH_k1YC@mail.gmail.com>
In-Reply-To
<201103192209.29759.jnareb@gmail.com>
On Sat, Mar 19, 2011 at 2:09 PM, Jakub Narebski <jnareb@gmail.com> wrote:
Show 13 quoted lines
>> For the $feature{'localtime'} disabled case, the coloring is the same as before.
>
> No, it is not the same.  It used to be
>
>  Wed, 16 Mar 2011 07:02:42 +0000 (02:02 -0500)
>                                   ^^^^^
>
> and now it is
>
>  Wed, 16 Mar 2011 07:02:42 +0000 (02:02 -0500)
>                                  ^^^^^^^^^^^^^
> which is I also think improvement,... but should be mentioned in the
> commit message.
Oh OK, I did not notice this or intend to change the formatting.  My bad.
Show 11 quoted lines
>> I will paint the whole line in the next spin, and mention it in the
>> commit message.
>
> I think current solution of using
>
>  Wed, 16 Mar 2011 02:02:42 -0500 (07:02:42 +0000)
>  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>
> when 'localtime' feature is enabled is better than painting the whole:
> you are now painting the _local_ part, i.e the part responsible for
> "atnight" warning.
I can fix up v4 if Junio thinks this is a better way to go...

It does make the code a little more complicated, though. If we paint the entire string, it can be done once toward the end of the function, rather than twice (two different ways) inside the localtime / no-localtime clauses.

I am largely indifferent to how "atnight" is handled but it would be good to arrive at a consensus.

Show 10 quoted lines
>> Also, is there a cleaner way of writing this?
>>
>> sub timestamp_html {
>>     my %date = %{$_[0]};
>>     shift;
>>     my %opts = @_;
>
>  sub timestamp_html {
>      my %date = %{ shift };
>      my %opts = @_;
This did not work for me.  It interprets "shift" as a variable name.
Show 6 quoted lines
> Or just use hash reference for $date:
>
>  sub timestamp_html {
>      my ($date, %opts) = @_;
>
> and use $date->{'sth'}.

That is what I did on the latest 3/3 (change "atnight" highlighting) patch. Seemed to work OK.

Thanks.
Previous: Jakub NarebskiNext: Jakub Narebski
Message 7 of 36 in “gitweb: rename parse_date() to format_date()”
  1. 1/2 gitweb: rename parse_date() to format_date()Kevin Cernekee, Mar 19, 2011
  2. 2/2 gitweb: introduce localtime featureKevin Cernekee, Mar 19, 2011
  3. Jakub NarebskiMar 19, 2011
  4. Junio C HamanoMar 19, 2011
  5. Kevin CernekeeMar 19, 2011
  6. Jakub NarebskiMar 19, 2011
  7. Kevin CernekeeMar 19, 2011
  8. Jakub NarebskiMar 19, 2011
  9. J.H.Mar 20, 2011
  10. Kevin CernekeeMar 20, 2011
  11. Jakub NarebskiMar 21, 2011
  12. J.H.Mar 21, 2011
  13. Jakub NarebskiMar 21, 2011
  14. Piotr KrukowieckiMar 21, 2011
  15. J.H.Mar 21, 2011
  16. Jakub NarebskiMar 21, 2011
  17. 0/1 Gitweb: Change timezoneJohn 'Warthog9' Hawley, Mar 24, 2011
  18. 1/1 gitweb: javascript ability to adjust time based on timezoneJohn 'Warthog9' Hawley, Mar 24, 2011
  19. Kevin CernekeeMar 24, 2011
  20. J.H.Mar 24, 2011
  21. Jakub NarebskiMar 24, 2011
  22. Jakub NarebskiMar 24, 2011
  23. Kevin CernekeeMar 24, 2011
  24. J.H.Mar 24, 2011
  25. J.H.Mar 24, 2011
  26. Jakub NarebskiMar 24, 2011
  27. Jakub NarebskiMar 24, 2011
  28. gitweb: Fix handling of fractional timezones in parse_dateJakub Narebski, Mar 25, 2011
  29. Kevin CernekeeMar 25, 2011
  30. gitweb: Fix handling of fractional timezones in parse_dateJakub Narebski, Mar 25, 2011
  31. Junio C HamanoMar 25, 2011
  32. Jakub NarebskiMar 25, 2011
  33. gitweb: Fix handling of fractional timezones in parse_dateJakub Narebski, Mar 25, 2011
  34. Jakub NarebskiMar 19, 2011
  35. Jon SeymourMar 19, 2011
  36. Junio C HamanoMar 19, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.