git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v4 2/2] gitweb: introduce localtime feature

From
Jakub Narebski <jnareb@gmail.com>
Date
Mar 19, 2011, 21:09 UTC
Message-ID
<201103192209.29759.jnareb@gmail.com>
In-Reply-To
<AANLkTimssscn+STEPyM7NbXF5ddFApPBsgXfqz-9SSNs@mail.gmail.com>
On Sat, 19 Mar 2011, Kevin Cernekee wrote:
> On Sat, Mar 19, 2011 at 10:56 AM, Junio C Hamano <gitster@pobox.com> wrote:
Show 9 quoted lines
> > Looks like we used to only paint HH:MM part but...
> > ... we now paint the whole line, which I personally think is a friendly
> > move for color challenged people (me included---a larger span of text
> > painted in different colors tends to help you still notice it better using
> > value/brightness difference, even if your hue perception is weaker than
> > other people). But it is a change from the old behaviour and might be
> > worth stating in the log message.
> 
> For the $feature{'localtime'} disabled case, the coloring is the same as before.
No, it is not the same.  It used to be
  Wed, 16 Mar 2011 07:02:42 +0000 (02:02 -0500)
                                   ^^^^^
and now it is
  Wed, 16 Mar 2011 07:02:42 +0000 (02:02 -0500)
                                  ^^^^^^^^^^^^^
which is I also think improvement,... but should be mentioned in the
commit message.
 
> I will paint the whole line in the next spin, and mention it in the
> commit message.
I think current solution of using
  Wed, 16 Mar 2011 02:02:42 -0500 (07:02:42 +0000)
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

when 'localtime' feature is enabled is better than painting the whole: you are now painting the _local_ part, i.e the part responsible for "atnight" warning.

[...]
Show 9 quoted lines
> $use_localtime indicates whether or not to add the " (hh:mm -zzzz)" at
> the end.  This also enables the atnight coloring.
> 
> This argument name was suggested in an earlier post and I guess I took
> it a little too literally...
> 
> Do you think it would be a good idea to take two separate options:
> -atnight for the variable coloring, and -alt_time (or some other name)
> to show " (hh:mm -zzzz)" after the RFC 2822 string?
Perhaps name this parameter -long.  Or simply always use the long form.
Show 10 quoted lines
> Or maybe take one option, named something like "-commitpage", to
> indicate that it is a format specific to that view?  If it is not
> specified, the caller gets back an uncolored RFC 2822 date.
> 
> Also, is there a cleaner way of writing this?
> 
> sub timestamp_html {
>     my %date = %{$_[0]};
>     shift;
>     my %opts = @_;
  sub timestamp_html {
      my %date = %{ shift };
      my %opts = @_;
Show 6 quoted lines
> 
> Or should I pass in the options as a hash reference, more like $cgi->a():
> 
> sub timestamp_html {
>     my %date = %{$_[0]};
>     my %opts = %{$_[1]};
Or just use hash reference for $date:
  sub timestamp_html {
      my ($date, %opts) = @_;
and use $date->{'sth'}.
-- 
Jakub Narebski
Poland
Previous: Kevin CernekeeNext: Kevin Cernekee
Message 6 of 36 in “gitweb: rename parse_date() to format_date()”
  1. 1/2 gitweb: rename parse_date() to format_date()Kevin Cernekee, Mar 19, 2011
  2. 2/2 gitweb: introduce localtime featureKevin Cernekee, Mar 19, 2011
  3. Jakub NarebskiMar 19, 2011
  4. Junio C HamanoMar 19, 2011
  5. Kevin CernekeeMar 19, 2011
  6. Jakub NarebskiMar 19, 2011
  7. Kevin CernekeeMar 19, 2011
  8. Jakub NarebskiMar 19, 2011
  9. J.H.Mar 20, 2011
  10. Kevin CernekeeMar 20, 2011
  11. Jakub NarebskiMar 21, 2011
  12. J.H.Mar 21, 2011
  13. Jakub NarebskiMar 21, 2011
  14. Piotr KrukowieckiMar 21, 2011
  15. J.H.Mar 21, 2011
  16. Jakub NarebskiMar 21, 2011
  17. 0/1 Gitweb: Change timezoneJohn 'Warthog9' Hawley, Mar 24, 2011
  18. 1/1 gitweb: javascript ability to adjust time based on timezoneJohn 'Warthog9' Hawley, Mar 24, 2011
  19. Kevin CernekeeMar 24, 2011
  20. J.H.Mar 24, 2011
  21. Jakub NarebskiMar 24, 2011
  22. Jakub NarebskiMar 24, 2011
  23. Kevin CernekeeMar 24, 2011
  24. J.H.Mar 24, 2011
  25. J.H.Mar 24, 2011
  26. Jakub NarebskiMar 24, 2011
  27. Jakub NarebskiMar 24, 2011
  28. gitweb: Fix handling of fractional timezones in parse_dateJakub Narebski, Mar 25, 2011
  29. Kevin CernekeeMar 25, 2011
  30. gitweb: Fix handling of fractional timezones in parse_dateJakub Narebski, Mar 25, 2011
  31. Junio C HamanoMar 25, 2011
  32. Jakub NarebskiMar 25, 2011
  33. gitweb: Fix handling of fractional timezones in parse_dateJakub Narebski, Mar 25, 2011
  34. Jakub NarebskiMar 19, 2011
  35. Jon SeymourMar 19, 2011
  36. Junio C HamanoMar 19, 2011

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.