Re: [PATCH v4 15/16] refs.c: remove fallback-to-main-store code get_submodule_ref_store()
On 08/23/2017 02:37 PM, Nguyễn Thái Ngọc Duy wrote:
Show 20 quoted lines
> At this state, there are three get_submodule_ref_store() callers:
>
> - for_each_remote_ref_submodule()
> - handle_revision_pseudo_opt()
> - resolve_gitlink_ref()
>
> The first two deal explicitly with submodules (and we should never fall
> back to the main ref store as a result). They are only called from
> submodule.c:
>
> - find_first_merges()
> - submodule_needs_pushing()
> - push_submodule()
>
> The last one, as its name implies, deals only with submodules too, and
> the "submodule" (path) argument must be a non-NULL, non-empty string.
>
> So, this "if NULL or empty string" code block should never ever
> trigger. And it's wrong to fall back to the main ref store
> anyway. Delete it.
Nice! Thanks for the cleanup.
Michael