git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH] refs.h: rename submodule arguments to submodule_path

From
Michael Haggerty <mhagger@alum.mit.edu>
Date
Apr 21, 2017, 06:42 UTC
Message-ID
<8b2ef70c-4064-f726-8752-5bb0a898ee7a@alum.mit.edu>
In-Reply-To
<cb1dd8b6-3357-57ff-650d-c55a7eb38d34@alum.mit.edu>
On 04/21/2017 08:32 AM, Michael Haggerty wrote:
Show 6 quoted lines
> [...]
> I've CCed Duy because I don't know whether he has more plans regarding
> submodule references [...] get rid of the
> `for_each_ref_submodule()` family of functions entirely.
> 
> So perhaps the code that this patch touches won't be around long anyway.

Oh yeah, he has done exactly that in his nd/prune-in-worktree patch series. (I knew I'd seen that somewhere...)

So it seems that the argument renaming has mostly been overtaken by events, though even after Duy's patch series there are a few `const char *submodule` arguments that could be renamed.

Michael
Previous: Michael HaggertyNext: Duy Nguyen
Message 5 of 6 in “refs.h: rename submodule arguments to submodule_path”
  1. refs.h: rename submodule arguments to submodule_pathStefan Beller, Apr 12, 2017
  2. Stefan BellerApr 20, 2017
  3. Junio C HamanoApr 21, 2017
  4. Michael HaggertyApr 21, 2017
  5. Michael HaggertyApr 21, 2017
  6. Duy NguyenApr 21, 2017

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.