git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 0/5] pretty format %(trailers): improve machine readability

From
Anders Waldenborg <anders@0x63.nu>
Date
Dec 5, 2020, 18:18 UTC
Message-ID
<87wnxwp15o.fsf@0x63.nu>
In-Reply-To
<20201205013918.18981-1-avarab@gmail.com>
Ævar Arnfjörð Bjarmason writes:
Show 6 quoted lines
> I started writing this on top of "master", but then saw the
> outstanding series of other miscellaneous fixes to this
> facility[1]. This is on top of that topic & rebased on master.
>
> Anders, any plans to re-roll yours? Otherwise the conflicts I'd have
> on mine are easy to fix, so I can also submit it as a stand-alone.

Yes, I have plans to do that. But have yet to carve out the required time from my copious spare time to actually do it.

So please don't hold your breath waiting for me to do that.
Show 7 quoted lines
> This series comes out of a discussion at work today (well, yesterday
> at this point) where someone wanted to parse %(trailers) output. As
> noted in 3/5 doing this is rather tedious now if you're trying to
> unambiguously grap trailers as a stream of key-value pairs.
>
> So this series adds a "key_value_separator" and "keyonly" parameters,
> and fixes a few bugs I saw along the way.

Interesting. When adding "valueonly" I never consider it being used without "key". The trick you are doing with separate keyonly and valueonly is quite clever.

I've only been doing machine parsing for explicit keys, things like: "%cn%x00%x00%an%x00%x00%(trailers:key=Reviewed-By,valueonly,unfold,separator=%x00)%x00%x00%(trailers:key=Backport-Reviewed-By,valueonly,unfold,separator=%x00)" (double-NUL to separate field, single-NUL to separate values within field).

But I can't help wonder that if the goal just is to have a nice machine parsable format maybe it would be easier (both for user and implementation) to have a separate placeholder for "machine readable trailers" which by default emits in a format suitable for machine parsing. Something like a new "%(ztrailers)" (but with a better name) which simply emits a sequence of "<KEY> NUL <VAL> NUL" for each trailer.

Previous: Ævar Arnfjörð BjarmasonNext: Ævar Arnfjörð Bjarmason
Message 39 of 67 in “trailer fixes”
  1. 00/21 trailer fixesAnders Waldenborg, Oct 25, 2020
  2. 06/21 t4205: add test for trailer in log with nonstandard separatorAnders Waldenborg, Oct 25, 2020
  3. Christian CouderOct 26, 2020
  4. Anders WaldenborgNov 9, 2020
  5. Christian CouderNov 10, 2020
  6. Jeff KingNov 10, 2020
  7. 03/21 doc: mention canonicalization in git i-t manualAnders Waldenborg, Oct 25, 2020
  8. Christian CouderOct 26, 2020
  9. 19/21 trailer: move config lookup out of parse_trailerAnders Waldenborg, Oct 25, 2020
  10. 20/21 trailer: add failing tests for matching trailers against inputAnders Waldenborg, Oct 25, 2020
  11. 13/21 trailer: add option to make canonicalization optionalAnders Waldenborg, Oct 25, 2020
  12. Jeff KingNov 10, 2020
  13. 07/21 trailer: simplify 'arg_item' lifetimeAnders Waldenborg, Oct 25, 2020
  14. 14/21 trailer: move skipping of blank lines to own loop when finding trailerAnders Waldenborg, Oct 25, 2020
  15. 04/21 pretty: allow using aliases in %(trailer:key=xyz)Anders Waldenborg, Oct 25, 2020
  16. Christian CouderOct 26, 2020
  17. 09/21 trailer: refactor print_tok_val into taking itemAnders Waldenborg, Oct 25, 2020
  18. 10/21 trailer: move trailer token canonicalization print timeAnders Waldenborg, Oct 25, 2020
  19. 08/21 trailer: keep track of conf in trailer_itemAnders Waldenborg, Oct 25, 2020
  20. Jeff KingNov 10, 2020
  21. 17/21 trailer: don't treat line with prefix of known trailer as knownAnders Waldenborg, Oct 25, 2020
  22. Jeff KingNov 10, 2020
  23. 16/21 t7513: add failing test for configured trailing line classificationAnders Waldenborg, Oct 25, 2020
  24. 02/21 trailer: don't use 'struct arg_item' for storing configAnders Waldenborg, Oct 25, 2020
  25. 12/21 trailer: handle configured nondefault separators explicitlyAnders Waldenborg, Oct 25, 2020
  26. Jeff KingNov 10, 2020
  27. 11/21 trailer: remember separator used in inputAnders Waldenborg, Oct 25, 2020
  28. 18/21 trailer: factor out config lookup to separate functionAnders Waldenborg, Oct 25, 2020
  29. 05/21 trailer: rename 'free_all' to 'free_all_trailer_items'Anders Waldenborg, Oct 25, 2020
  30. Christian CouderOct 26, 2020
  31. Jeff KingNov 10, 2020
  32. 01/21 trailer: change token_{from,matches}_item into taking conf_infoAnders Waldenborg, Oct 25, 2020
  33. Christian CouderOct 26, 2020
  34. 15/21 trailer: factor out classify_trailer_lineAnders Waldenborg, Oct 25, 2020
  35. 21/21 trailer: only do prefix matching for configured trailers on commandlineAnders Waldenborg, Oct 25, 2020
  36. Christian CouderNov 10, 2020
  37. 1/5 pretty format %(trailers) test: split a long lineÆvar Arnfjörð Bjarmason, Dec 5, 2020
  38. 0/5 pretty format %(trailers): improve machine readabilityÆvar Arnfjörð Bjarmason, Dec 5, 2020
  39. Anders WaldenborgDec 5, 2020
  40. Ævar Arnfjörð BjarmasonDec 7, 2020
  41. 2/5 pretty format %(trailers) doc: avoid repetitionÆvar Arnfjörð Bjarmason, Dec 6, 2020
  42. Christian CouderDec 7, 2020
  43. 4/5 pretty format %(trailers): add a "keyonly"Ævar Arnfjörð Bjarmason, Dec 6, 2020
  44. Christian CouderDec 7, 2020
  45. 1/5 pretty format %(trailers) test: split a long lineÆvar Arnfjörð Bjarmason, Dec 6, 2020
  46. 3/5 pretty-format %(trailers): fix broken standalone "valueonly"Ævar Arnfjörð Bjarmason, Dec 6, 2020
  47. 0/5 pretty format %(trailers): improve machine readabilityÆvar Arnfjörð Bjarmason, Dec 6, 2020
  48. 1/5 pretty format %(trailers) test: split a long lineÆvar Arnfjörð Bjarmason, Dec 9, 2020
  49. 5/5 pretty format %(trailers): add a "key_value_separator"Ævar Arnfjörð Bjarmason, Dec 9, 2020
  50. 4/5 pretty format %(trailers): add a "keyonly"Ævar Arnfjörð Bjarmason, Dec 9, 2020
  51. 3/5 pretty-format %(trailers): fix broken standalone "valueonly"Ævar Arnfjörð Bjarmason, Dec 9, 2020
  52. 2/5 pretty format %(trailers) doc: avoid repetitionÆvar Arnfjörð Bjarmason, Dec 9, 2020
  53. Junio C HamanoDec 10, 2020
  54. 0/5 pretty format %(trailers): improve machine readabilityÆvar Arnfjörð Bjarmason, Dec 9, 2020
  55. Christian CouderDec 10, 2020
  56. Junio C HamanoDec 10, 2020
  57. 5/5 pretty format %(trailers): add a "key_value_separator"Ævar Arnfjörð Bjarmason, Dec 6, 2020
  58. 3/5 pretty format %(trailers): add a "keyonly"Ævar Arnfjörð Bjarmason, Dec 5, 2020
  59. Christian CouderDec 5, 2020
  60. Ævar Arnfjörð BjarmasonDec 5, 2020
  61. 2/5 pretty format %(trailers): avoid needless repetitionÆvar Arnfjörð Bjarmason, Dec 5, 2020
  62. Christian CouderDec 5, 2020
  63. 4/5 pretty-format %(trailers): fix broken standalone "valueonly"Ævar Arnfjörð Bjarmason, Dec 5, 2020
  64. Christian CouderDec 5, 2020
  65. 5/5 pretty format %(trailers): add a "key_value_separator"Ævar Arnfjörð Bjarmason, Dec 5, 2020
  66. Christian CouderDec 5, 2020
  67. Ævar Arnfjörð BjarmasonDec 5, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.