git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH 13/21] trailer: add option to make canonicalization optional

From
Jeff King <peff@peff.net>
Date
Nov 10, 2020, 20:10 UTC
Message-ID
<20201110201040.GF1987088@coredump.intra.peff.net>
In-Reply-To
<20201025212652.3003036-14-anders@0x63.nu>
On Sun, Oct 25, 2020 at 10:26:44PM +0100, Anders Waldenborg wrote:
Show 10 quoted lines
> Adds a new `--(no-)canonicalize` option to interpret-trailers. By
> default it is on unless `--parse` option is given.
> 
> When option is on trailer tokens and separators get canonicalized to
> the form they have in config (if there is any config for that
> trailer). This is same behavior as before this patch, which allows
> this behavior to be disabled with `--no-canonicalize`. `--parse` now
> also implies `--no-canonicalize`, if previous behavior with
> canonicalization also in parse mode is wanted it needs to be combined
> with `--parse --canonicalize`

I'm not sure if this should be tied to --parse or not. The idea of --parse is that you'd normalize syntactic issues to make it easy to parse the result. But wouldn't normalizing names around spelling or capitalization be what you'd usually want there?

So it sounds like you'd want it to _always_ be on, but leave "--no-canonicalize" as an escape hatch for somebody who's researching spelling variants.

Or maybe I'm misunderstanding what it does, since...
Show 16 quoted lines
> --- a/Documentation/git-interpret-trailers.txt
> +++ b/Documentation/git-interpret-trailers.txt
> @@ -129,13 +129,16 @@ OPTIONS
>  
>  --parse::
>  	A convenience alias for `--only-trailers --only-input
> -	--unfold`.
> +	--unfold --no-canonicalize`.
>  
>  --no-divider::
>  	Do not treat `---` as the end of the commit message. Use this
>  	when you know your input contains just the commit message itself
>  	(and not an email or the output of `git format-patch`).
>  
> +--no-canonicalize::
> +	Disable canonicalization of input trailers.
I think this needs to define "canonicalization" here.
-Peff
Previous: Anders WaldenborgNext: Anders Waldenborg
Message 12 of 67 in “trailer fixes”
  1. 00/21 trailer fixesAnders Waldenborg, Oct 25, 2020
  2. 06/21 t4205: add test for trailer in log with nonstandard separatorAnders Waldenborg, Oct 25, 2020
  3. Christian CouderOct 26, 2020
  4. Anders WaldenborgNov 9, 2020
  5. Christian CouderNov 10, 2020
  6. Jeff KingNov 10, 2020
  7. 03/21 doc: mention canonicalization in git i-t manualAnders Waldenborg, Oct 25, 2020
  8. Christian CouderOct 26, 2020
  9. 19/21 trailer: move config lookup out of parse_trailerAnders Waldenborg, Oct 25, 2020
  10. 20/21 trailer: add failing tests for matching trailers against inputAnders Waldenborg, Oct 25, 2020
  11. 13/21 trailer: add option to make canonicalization optionalAnders Waldenborg, Oct 25, 2020
  12. Jeff KingNov 10, 2020
  13. 07/21 trailer: simplify 'arg_item' lifetimeAnders Waldenborg, Oct 25, 2020
  14. 14/21 trailer: move skipping of blank lines to own loop when finding trailerAnders Waldenborg, Oct 25, 2020
  15. 04/21 pretty: allow using aliases in %(trailer:key=xyz)Anders Waldenborg, Oct 25, 2020
  16. Christian CouderOct 26, 2020
  17. 09/21 trailer: refactor print_tok_val into taking itemAnders Waldenborg, Oct 25, 2020
  18. 10/21 trailer: move trailer token canonicalization print timeAnders Waldenborg, Oct 25, 2020
  19. 08/21 trailer: keep track of conf in trailer_itemAnders Waldenborg, Oct 25, 2020
  20. Jeff KingNov 10, 2020
  21. 17/21 trailer: don't treat line with prefix of known trailer as knownAnders Waldenborg, Oct 25, 2020
  22. Jeff KingNov 10, 2020
  23. 16/21 t7513: add failing test for configured trailing line classificationAnders Waldenborg, Oct 25, 2020
  24. 02/21 trailer: don't use 'struct arg_item' for storing configAnders Waldenborg, Oct 25, 2020
  25. 12/21 trailer: handle configured nondefault separators explicitlyAnders Waldenborg, Oct 25, 2020
  26. Jeff KingNov 10, 2020
  27. 11/21 trailer: remember separator used in inputAnders Waldenborg, Oct 25, 2020
  28. 18/21 trailer: factor out config lookup to separate functionAnders Waldenborg, Oct 25, 2020
  29. 05/21 trailer: rename 'free_all' to 'free_all_trailer_items'Anders Waldenborg, Oct 25, 2020
  30. Christian CouderOct 26, 2020
  31. Jeff KingNov 10, 2020
  32. 01/21 trailer: change token_{from,matches}_item into taking conf_infoAnders Waldenborg, Oct 25, 2020
  33. Christian CouderOct 26, 2020
  34. 15/21 trailer: factor out classify_trailer_lineAnders Waldenborg, Oct 25, 2020
  35. 21/21 trailer: only do prefix matching for configured trailers on commandlineAnders Waldenborg, Oct 25, 2020
  36. Christian CouderNov 10, 2020
  37. 1/5 pretty format %(trailers) test: split a long lineÆvar Arnfjörð Bjarmason, Dec 5, 2020
  38. 0/5 pretty format %(trailers): improve machine readabilityÆvar Arnfjörð Bjarmason, Dec 5, 2020
  39. Anders WaldenborgDec 5, 2020
  40. Ævar Arnfjörð BjarmasonDec 7, 2020
  41. 2/5 pretty format %(trailers) doc: avoid repetitionÆvar Arnfjörð Bjarmason, Dec 6, 2020
  42. Christian CouderDec 7, 2020
  43. 4/5 pretty format %(trailers): add a "keyonly"Ævar Arnfjörð Bjarmason, Dec 6, 2020
  44. Christian CouderDec 7, 2020
  45. 1/5 pretty format %(trailers) test: split a long lineÆvar Arnfjörð Bjarmason, Dec 6, 2020
  46. 3/5 pretty-format %(trailers): fix broken standalone "valueonly"Ævar Arnfjörð Bjarmason, Dec 6, 2020
  47. 0/5 pretty format %(trailers): improve machine readabilityÆvar Arnfjörð Bjarmason, Dec 6, 2020
  48. 1/5 pretty format %(trailers) test: split a long lineÆvar Arnfjörð Bjarmason, Dec 9, 2020
  49. 5/5 pretty format %(trailers): add a "key_value_separator"Ævar Arnfjörð Bjarmason, Dec 9, 2020
  50. 4/5 pretty format %(trailers): add a "keyonly"Ævar Arnfjörð Bjarmason, Dec 9, 2020
  51. 3/5 pretty-format %(trailers): fix broken standalone "valueonly"Ævar Arnfjörð Bjarmason, Dec 9, 2020
  52. 2/5 pretty format %(trailers) doc: avoid repetitionÆvar Arnfjörð Bjarmason, Dec 9, 2020
  53. Junio C HamanoDec 10, 2020
  54. 0/5 pretty format %(trailers): improve machine readabilityÆvar Arnfjörð Bjarmason, Dec 9, 2020
  55. Christian CouderDec 10, 2020
  56. Junio C HamanoDec 10, 2020
  57. 5/5 pretty format %(trailers): add a "key_value_separator"Ævar Arnfjörð Bjarmason, Dec 6, 2020
  58. 3/5 pretty format %(trailers): add a "keyonly"Ævar Arnfjörð Bjarmason, Dec 5, 2020
  59. Christian CouderDec 5, 2020
  60. Ævar Arnfjörð BjarmasonDec 5, 2020
  61. 2/5 pretty format %(trailers): avoid needless repetitionÆvar Arnfjörð Bjarmason, Dec 5, 2020
  62. Christian CouderDec 5, 2020
  63. 4/5 pretty-format %(trailers): fix broken standalone "valueonly"Ævar Arnfjörð Bjarmason, Dec 5, 2020
  64. Christian CouderDec 5, 2020
  65. 5/5 pretty format %(trailers): add a "key_value_separator"Ævar Arnfjörð Bjarmason, Dec 5, 2020
  66. Christian CouderDec 5, 2020
  67. Ævar Arnfjörð BjarmasonDec 5, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.