Re: fatal: Out of memory, malloc failed
- From
Alex Riesen <raa.lkml@gmail.com>
- Date
- Apr 16, 2007, 08:03 UTC
- Message-ID
- <81b0412b0704160103p15924e94idfaa445a30fe8e81@mail.gmail.com>
- In-Reply-To
- <Pine.LNX.4.64.0704160853050.7680@beast.quantumfyre.co.uk>
On 4/16/07, Julian Phillips <julian@quantumfyre.co.uk> wrote:
Show 8 quoted lines
> > > > Thats what I thought, but malloc continued to fail until the 72Mb file was removed. > > > > No, my server is running Debian. I had the push problem when logged in on that. > > It worked when I pushed it from a Gentoo box. > > a problem with ulimit -m on the server? >
Nah, a process gets killed in case of a limit hit. He gets malloc returning NULL.