Re: [PATCH] diesys calls die and also reports strerror(errno)
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jun 5, 2009, 07:12 UTC
- Message-ID
- <7vtz2vnogt.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <4A28BA3E.3090800@viscovery.net>
Johannes Sixt <j.sixt@viscovery.net> writes:
Show 6 quoted lines
> Jeff King schrieb: >> On Thu, Jun 04, 2009 at 06:05:05AM +0400, Alexander Potashev wrote: >>> +void diesys(const char *err, ...) > > Am I the only one who thinks that 'die_errno' would be a better name for > this function?
You are not alone. I did find diesys() unreadable, but simply did not think of an obviously better alternative like you did.