From: Junio C Hamano Date: Fri, 05 Jun 2009 07:12:34 GMT Subject: Re: [PATCH] diesys calls die and also reports strerror(errno) Message-ID: <7vtz2vnogt.fsf@alter.siamese.dyndns.org> In-Reply-To: <4A28BA3E.3090800@viscovery.net> Johannes Sixt writes: > Jeff King schrieb: >> On Thu, Jun 04, 2009 at 06:05:05AM +0400, Alexander Potashev wrote: >>> +void diesys(const char *err, ...) > > Am I the only one who thinks that 'die_errno' would be a better name for > this function? You are not alone. I did find diesys() unreadable, but simply did not think of an obviously better alternative like you did.