Re: [PATCH] git-svn now work with crlf convertion enabled.
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 1, 2008, 22:14 UTC
- Message-ID
- <7vr698qt6w.fsf@gitster.siamese.dyndns.org>
- In-Reply-To
- <20080801220932.GK7008@dpotapov.dyndns.org>
Dmitry Potapov <dpotapov@gmail.com> writes:
Show 8 quoted lines
> I have applied your patch and then corrected mine to use flags. > See below. > > I wonder if something should be done about other places where index_xx > functions are called. I have looked at them and all they use either 0 or > 1 (boolean expression which will be evaluated to 0 or 1), so they should > work as is, but I can correct them to use HASH_OBJECT_DO_CREATE instead > of 1 if it helps with readability.
Even though the patch was not compile tested, I did check the existing call sites are giving only 0 or 1, but I think converting these "please write -- I give you 1" callers to pass the bitmask would be a sane thing to do.