Re: [PATCH 2/3] diff: refactor the word-diff setup from builtin_diff_cmd
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 14, 2012, 19:26 UTC
- Message-ID
- <7vobrzoug4.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <9f2f3a870a8d88850444090318647f3c7b8c0743.1331749299.git.trast@student.ethz.ch>
Thomas Rast <trast@student.ethz.ch> writes:
> Quite a chunk of builtin_diff_cmd deals with word-diff setup, defaults > and such. This makes the function a bit hard to read, but is also > asymmetric because the corresponding teardown lives in free_diff_words_data > already.
Yay! "A bit hard to read" is a gross understatement ;-)
Whether the series fixes a bug of not, this alone makes the patch worthwhile to look.
Thanks.