Re: [PATCH 04/17] Name local variables more consistently
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 27, 2012, 16:55 UTC
- Message-ID
- <7voblws299.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <20120827092502.GA2428@sigill.intra.peff.net>
Jeff King <peff@peff.net> writes:
> Yeah, I agree that "refnames" would be better. I think something like > "spec" or "refspec" would indicate better that they are to be matched > against, but then you run afoul of confusing that with colon-delimited > refspecs (which I do not think fetch-pack understands at all).
Correct. It only takes the LHS of the refspecs, following the "one tool does one specific thing" philosophy. The arrangement was that the calling script interpreted refspecs, split them into LHS and RHS, fed the LHS of the refspecs to fetch-pack, and then read the output to learn which local refs (i.e. RHS of the refspecs) to update with what value.