Re: [PATCH 04/17] Name local variables more consistently
- From
Jeff King <peff@peff.net>
- Date
- Aug 23, 2012, 08:39 UTC
- Message-ID
- <20120823083918.GB6963@sigill.intra.peff.net>
- In-Reply-To
- <1345709442-16046-5-git-send-email-mhagger@alum.mit.edu>
On Thu, Aug 23, 2012 at 10:10:29AM +0200, mhagger@alum.mit.edu wrote:
> From: Michael Haggerty <mhagger@alum.mit.edu> > > Use the names (nr_heads, heads) consistently across functions, instead > of sometimes naming the same values (nr_match, match).
I think this is fine, although:
Show 14 quoted lines
> --- a/builtin/fetch-pack.c
> +++ b/builtin/fetch-pack.c
> @@ -521,7 +521,7 @@ static void mark_recent_complete_commits(unsigned long cutoff)
> }
> }
>
> -static void filter_refs(struct ref **refs, int nr_match, char **match)
> +static void filter_refs(struct ref **refs, int nr_heads, char **heads)
> {
> struct ref **return_refs;
> struct ref *newlist = NULL;
> @@ -530,12 +530,12 @@ static void filter_refs(struct ref **refs, int nr_match, char **match)
> struct ref *fastarray[32];
> int match_pos;This match_pos is an index into the "match" array, which becomes "head". Should it become head_pos?
And then bits like this:
> - while (match_pos < nr_match) {
> - cmp = strcmp(ref->name, match[match_pos]);
> + while (match_pos < nr_heads) {
> + cmp = strcmp(ref->name, heads[match_pos]);Would be:
while (head_pos < nr_heads)
which makes more sense to me.
-Peff