git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: as/check-ignore (was Re: What's cooking in git.git (Jan 2013, #02; Thu, 3))

From
Junio C Hamano <gitster@pobox.com>
Date
Jan 4, 2013, 21:13 UTC
Message-ID
<7vobh4tzx3.fsf@alter.siamese.dyndns.org>
In-Reply-To
<CAOkDyE-f-8XZAzWrQgh_DG=fZctqBFXqpog-FSDU_yeXfwWTwA@mail.gmail.com>
Adam Spiers <git@adamspiers.org> writes:
Show 29 quoted lines
> On Thu, Jan 3, 2013 at 7:17 PM, Junio C Hamano <gitster@pobox.com> wrote:
>> * as/check-ignore (2012-12-28) 19 commits
>>  - Add git-check-ignore sub-command
>>  - setup.c: document get_pathspec()
>>  - pathspec.c: extract new validate_path() for reuse
>>  - pathspec.c: move reusable code from builtin/add.c
>>  - add.c: remove unused argument from validate_pathspec()
>>  - add.c: refactor treat_gitlinks()
>>  - dir.c: provide clear_directory() for reclaiming dir_struct memory
>>  - dir.c: keep track of where patterns came from
>>  - dir.c: use a single struct exclude_list per source of excludes
>>  - dir.c: rename free_excludes() to clear_exclude_list()
>>  - dir.c: refactor is_path_excluded()
>>  - dir.c: refactor is_excluded()
>>  - dir.c: refactor is_excluded_from_list()
>>  - dir.c: rename excluded() to is_excluded()
>>  - dir.c: rename excluded_from_list() to is_excluded_from_list()
>>  - dir.c: rename path_excluded() to is_path_excluded()
>>  - dir.c: rename cryptic 'which' variable to more consistent name
>>  - Improve documentation and comments regarding directory traversal API
>>  - api-directory-listing.txt: update to match code
>>
>>  Rerolled.  The early parts looked mostly fine; we may want to split
>>  this into two topics and have the early half graduate sooner.
>
> Sounds good to me.  As already mentioned, I have the v4 series ready
> and it addresses all issues already voiced in v3, but I have postponed
> submitting it as per your request.  Please let me know when and how to
> proceed, thanks!

I was planning to add a new "as/dir-c-cleanup" topic that leads to f619881 (dir.c: rename free_excludes() to clear_exclude_list(), 2012-12-27), and leave the remainder in this series. I think the earlier parts of this series up to that point should go 'next' now.

Previous: Adam SpiersNext: Adam Spiers
Message 3 of 16 in “What's cooking in git.git (Jan 2013, #02; Thu, 3)”
  1. Junio C HamanoJan 3, 2013
  2. Adam SpiersJan 4, 2013
  3. Junio C HamanoJan 4, 2013
  4. Adam SpiersJan 6, 2013
  5. 00/11 new git check-ignore sub-commandAdam Spiers, Jan 6, 2013
  6. 01/11 dir.c: use a single struct exclude_list per source of excludesAdam Spiers, Jan 6, 2013
  7. 02/11 dir.c: keep track of where patterns came fromAdam Spiers, Jan 6, 2013
  8. 03/11 dir.c: provide clear_directory() for reclaiming dir_struct memoryAdam Spiers, Jan 6, 2013
  9. 04/11 dir.c: improve docs for match_pathspec() and match_pathspec_depth()Adam Spiers, Jan 6, 2013
  10. 05/11 add.c: remove unused argument from validate_pathspec()Adam Spiers, Jan 6, 2013
  11. 06/11 add.c: move pathspec matchers into new pathspec.c for reuseAdam Spiers, Jan 6, 2013
  12. 07/11 pathspec.c: rename newly public functions for clarityAdam Spiers, Jan 6, 2013
  13. 08/11 add.c: extract check_path_for_gitlink() from treat_gitlinks() for reuseAdam Spiers, Jan 6, 2013
  14. 09/11 add.c: extract new die_if_path_beyond_symlink() for reuseAdam Spiers, Jan 6, 2013
  15. 10/11 setup.c: document get_pathspec()Adam Spiers, Jan 6, 2013
  16. 11/11 add git-check-ignore sub-commandAdam Spiers, Jan 6, 2013

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.