Re: as/check-ignore (was Re: What's cooking in git.git (Jan 2013, #02; Thu, 3))
On Fri, Jan 04, 2013 at 01:13:12PM -0800, Junio C Hamano wrote:
Show 35 quoted lines
> Adam Spiers <git@adamspiers.org> writes:
> > On Thu, Jan 3, 2013 at 7:17 PM, Junio C Hamano <gitster@pobox.com> wrote:
> >> * as/check-ignore (2012-12-28) 19 commits
> >> - Add git-check-ignore sub-command
> >> - setup.c: document get_pathspec()
> >> - pathspec.c: extract new validate_path() for reuse
> >> - pathspec.c: move reusable code from builtin/add.c
> >> - add.c: remove unused argument from validate_pathspec()
> >> - add.c: refactor treat_gitlinks()
> >> - dir.c: provide clear_directory() for reclaiming dir_struct memory
> >> - dir.c: keep track of where patterns came from
> >> - dir.c: use a single struct exclude_list per source of excludes
> >> - dir.c: rename free_excludes() to clear_exclude_list()
> >> - dir.c: refactor is_path_excluded()
> >> - dir.c: refactor is_excluded()
> >> - dir.c: refactor is_excluded_from_list()
> >> - dir.c: rename excluded() to is_excluded()
> >> - dir.c: rename excluded_from_list() to is_excluded_from_list()
> >> - dir.c: rename path_excluded() to is_path_excluded()
> >> - dir.c: rename cryptic 'which' variable to more consistent name
> >> - Improve documentation and comments regarding directory traversal API
> >> - api-directory-listing.txt: update to match code
> >>
> >> Rerolled. The early parts looked mostly fine; we may want to split
> >> this into two topics and have the early half graduate sooner.
> >
> > Sounds good to me. As already mentioned, I have the v4 series ready
> > and it addresses all issues already voiced in v3, but I have postponed
> > submitting it as per your request. Please let me know when and how to
> > proceed, thanks!
>
> I was planning to add a new "as/dir-c-cleanup" topic that leads to
> f619881 (dir.c: rename free_excludes() to clear_exclude_list(),
> 2012-12-27), and leave the remainder in this series. I think the
> earlier parts of this series up to that point should go 'next' now.
That sounds perfect; thanks. I'll rebase v4 on top of this and submit.