Re: [PATCH] t4018: introduce test cases for the internal hunk header patterns
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Dec 20, 2011, 20:08 UTC
- Message-ID
- <7vmxanj9b0.fsf@alter.siamese.dyndns.org>
- In-Reply-To
- <7vty4wkx19.fsf@alter.siamese.dyndns.org>
Junio C Hamano <gitster@pobox.com> writes:
Show 9 quoted lines
> Brandon Casey <casey@nrlssc.navy.mil> writes: > >> * new test cases can be dropped into the t4018 directory >> * filenames end with the pattern name e.g. .cpp .objc .matlab etc. >> * filenames should be descriptive since it will be used in the test >> suite output >> * broken test cases should be given a filename prefixed with "broken_" > > Cute. I like the general idea.
Actually, I do not like this "broken_" filename prefix part. Even though I can imagine "git show -M" would do a reasonable job, marking that a fix to a pattern makes a test that used not to pass succeed by renaming a file goes against the convention of changing one line to turn the "failure" to "success" in test_expect_failure used in normal tests.
Can we use stable filename that says what is being tested instead?