From: Junio C Hamano Date: Tue, 20 Dec 2011 20:08:03 GMT Subject: Re: [PATCH] t4018: introduce test cases for the internal hunk header patterns Message-ID: <7vmxanj9b0.fsf@alter.siamese.dyndns.org> In-Reply-To: <7vty4wkx19.fsf@alter.siamese.dyndns.org> Junio C Hamano writes: > Brandon Casey writes: > >> * new test cases can be dropped into the t4018 directory >> * filenames end with the pattern name e.g. .cpp .objc .matlab etc. >> * filenames should be descriptive since it will be used in the test >> suite output >> * broken test cases should be given a filename prefixed with "broken_" > > Cute. I like the general idea. Actually, I do not like this "broken_" filename prefix part. Even though I can imagine "git show -M" would do a reasonable job, marking that a fix to a pattern makes a test that used not to pass succeed by renaming a file goes against the convention of changing one line to turn the "failure" to "success" in test_expect_failure used in normal tests. Can we use stable filename that says what is being tested instead?