Re: [PATCH 2/2] builtin-reflog: fix deletion of HEAD entries
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Aug 10, 2008, 18:52 UTC
- Message-ID
- <7vej4w3dou.fsf@gitster.siamese.dyndns.org>
- In-Reply-To
- <1218360901-36215-1-git-send-email-pdebie@ai.rug.nl>
Pieter de Bie <pdebie@ai.rug.nl> writes:
Show 8 quoted lines
> On Aug 10, 2008, at 3:01 AM, Junio C Hamano wrote:
>>- if (!dwim_ref(argv[i], spec - argv[i], sha1, &ref)) {
>>+ if (!dwim_log(argv[i], spec - argv[i], sha1, &ref)) {
>
> This is also what add_reflog_for_walk() does, but that function tries to resolve
> the argv[i] part first, without doing the dwim_log().
>
> Perhaps we can also ...Sorry, I do not understand what you meant by the above comment.
- "This is also what add_reflog_for_walk() does" -- I take it you mean the use of dwim_log() instead of dwim_ref()?
- "... but that function tries to resolve the argv[i] part first" -- do
you mean the resolve_ref("HEAD"...) call inside "if (!*branch)"
codepath? That one serves different purposes than "delete HEAD@{42}". It is
about showing "@{42}" --- in order to show reflog for "the current
branch", it figures out the current branch by resolving "HEAD".In any case, what confuses me is I cannot tell if you do or do not have issues that I did not think of with the "s/dwim_ref/dwim_log/" change. Are you saying "no that cannot be a correct fix; see the way dwim_log() is used in add_reflog_for_walk() -- it does more than your one-liner"?
By the way, I think the idea of "Perhaps we can also..." part is good.